summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/sphinxcontrib-cheeseshop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/sphinxcontrib-cheeseshop')
-rw-r--r--dev-python/sphinxcontrib-cheeseshop/Manifest1
-rw-r--r--dev-python/sphinxcontrib-cheeseshop/metadata.xml14
-rw-r--r--dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2.ebuild32
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-cheeseshop/Manifest b/dev-python/sphinxcontrib-cheeseshop/Manifest
new file mode 100644
index 000000000000..a2300ef2a5f5
--- /dev/null
+++ b/dev-python/sphinxcontrib-cheeseshop/Manifest
@@ -0,0 +1 @@
+DIST sphinxcontrib-cheeseshop-0.2.tar.gz 3568 SHA256 d1a3bc4c1842868f959f7e14fa7390e64fa717823144286e7d15a25c3624b1ec SHA512 5d6c88c0c43f37b94ebe6a2a62f795a6f7d5d6c407b808d6b21d54c1775fc4b5f22466c13e61adc16ac7973ba11e99a66da8650c869856f766e6bb3a6e99923b WHIRLPOOL 171762e8e197b54412a48db928395a62a8003eec614584df36d427afb44ee55cbfb8d75534dc38046cfef1a72c1f9eb2e37617afc755ea5b40187f48a493fbf2
diff --git a/dev-python/sphinxcontrib-cheeseshop/metadata.xml b/dev-python/sphinxcontrib-cheeseshop/metadata.xml
new file mode 100644
index 000000000000..0f5079b0d605
--- /dev/null
+++ b/dev-python/sphinxcontrib-cheeseshop/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-cheeseshop</remote-id>
+ <remote-id type="bitbucket">birkenfeld/sphinx-contrib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2.ebuild b/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2.ebuild
new file mode 100644
index 000000000000..75a71064dbf6
--- /dev/null
+++ b/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension cheeseshop"
+HOMEPAGE="http://bitbucket.org/birkenfeld/sphinx-contrib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-python/sphinx-1.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ ebegin 'patching setup.py'
+ sed \
+ -e '5s/file/open/' \
+ -i setup.py
+ STATUS=$?
+ eend ${STATUS}
+ [[ ${STATUS} -gt 0 ]] && die
+
+ distutils-r1_python_prepare_all
+}