summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2016-08-31 09:49:09 +0200
committerTobias Klausmann <klausman@gentoo.org>2016-08-31 09:49:09 +0200
commitfe69890467252025970bca16b8e9f88b6dd85012 (patch)
tree1c39d72cee2d5b4eb545181e38ea9d301df85a92 /dev-python/sphinxcontrib-napoleon
parentdev-python/scapy-python3: Initial addition to the tree (diff)
downloadgentoo-fe69890467252025970bca16b8e9f88b6dd85012.tar.gz
gentoo-fe69890467252025970bca16b8e9f88b6dd85012.tar.bz2
gentoo-fe69890467252025970bca16b8e9f88b6dd85012.zip
dev-python/sphinxcontrib-napoleon: Initial addition to the tree
Diffstat (limited to 'dev-python/sphinxcontrib-napoleon')
-rw-r--r--dev-python/sphinxcontrib-napoleon/Manifest1
-rw-r--r--dev-python/sphinxcontrib-napoleon/files/no_installed_tests.patch11
-rw-r--r--dev-python/sphinxcontrib-napoleon/metadata.xml9
-rw-r--r--dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.5.2.ebuild38
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-napoleon/Manifest b/dev-python/sphinxcontrib-napoleon/Manifest
new file mode 100644
index 000000000000..39fc74bc8a27
--- /dev/null
+++ b/dev-python/sphinxcontrib-napoleon/Manifest
@@ -0,0 +1 @@
+DIST sphinxcontrib-napoleon-0.5.2.tar.gz 24939 SHA256 3babaf7da3d062a2feba71f747946d123187e12ef68329eb6974026b25d218b8 SHA512 5f8d31c4ce66a042aa0c79ec06b7592539154bd7a397c1898db0cbed15b9891c908bb1d51334ef0b759e5d44ac99cf124616f0e4b3a1b1253f0f92312c949a8c WHIRLPOOL e577861c4357719a75ef84166f4cb9059fadded3b629606674beb5bfbd242bf4efb15c2889731690f4be8555b7561fb7c7ded14df925ebc2d926f26c91889bf4
diff --git a/dev-python/sphinxcontrib-napoleon/files/no_installed_tests.patch b/dev-python/sphinxcontrib-napoleon/files/no_installed_tests.patch
new file mode 100644
index 000000000000..20ba790b8523
--- /dev/null
+++ b/dev-python/sphinxcontrib-napoleon/files/no_installed_tests.patch
@@ -0,0 +1,11 @@
+--- setup.py.orig 2016-08-03 16:43:35.775261808 +0200
++++ setup.py 2016-08-03 16:43:56.126054227 +0200
+@@ -43,7 +43,7 @@
+ 'Framework :: Sphinx :: Extension',
+ ],
+ platforms='any',
+- packages=find_packages(),
++ packages=["sphinxcontrib"],
+ include_package_data=True,
+ install_requires=reqs,
+ test_suite='nose.collector',
diff --git a/dev-python/sphinxcontrib-napoleon/metadata.xml b/dev-python/sphinxcontrib-napoleon/metadata.xml
new file mode 100644
index 000000000000..639c1bc61f6b
--- /dev/null
+++ b/dev-python/sphinxcontrib-napoleon/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>klausman@gentoo.org</email>
+ <name>Tobias Klausmann</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.5.2.ebuild b/dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.5.2.ebuild
new file mode 100644
index 000000000000..666bca589a0f
--- /dev/null
+++ b/dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.5.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Allow a different format in dosctrings for better clarity"
+HOMEPAGE="https://pypi.python.org/pypi/sphinxcontrib-napoleon"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=test
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/pockets-0.3[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ )
+"
+src_prepare() {
+ epatch "${FILESDIR}/no_installed_tests.patch" || die
+}
+
+python_test() {
+ nosetests tests || die "tests failed with ${EPYTHON}"
+}