summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-08-09 12:29:02 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-08-09 12:30:19 -0500
commitc08296a602663494d4f5fadf60fcbb8e08414331 (patch)
tree19d46a2dd53a173ed813d38595246f188d9c0331 /dev-python/sphinxcontrib-newsfeed
parentmedia-sound/ncmpcpp: x86 stable wrt bug #556996 (diff)
downloadgentoo-c08296a602663494d4f5fadf60fcbb8e08414331.tar.gz
gentoo-c08296a602663494d4f5fadf60fcbb8e08414331.tar.bz2
gentoo-c08296a602663494d4f5fadf60fcbb8e08414331.zip
dev-python/sphinxcontrib-newsfeed: add version 0.1.4
Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-python/sphinxcontrib-newsfeed')
-rw-r--r--dev-python/sphinxcontrib-newsfeed/Manifest1
-rw-r--r--dev-python/sphinxcontrib-newsfeed/metadata.xml10
-rw-r--r--dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild26
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-newsfeed/Manifest b/dev-python/sphinxcontrib-newsfeed/Manifest
new file mode 100644
index 000000000000..1f6429b74c65
--- /dev/null
+++ b/dev-python/sphinxcontrib-newsfeed/Manifest
@@ -0,0 +1 @@
+DIST sphinxcontrib-newsfeed-0.1.4.tar.gz 10862 SHA256 f78c865b1a32d249644a9c46f395b547df0dc21ed69b70898d64235b4755efb4 SHA512 96d9d0c15fca8b62f945bafc8f0eafa62df9c471f7510e2f153e47b66534e5f3041e5c01df772e6c35a9f09baa70064642f7f0fa43ccfd33dd64c2604494f2fc WHIRLPOOL f14e5c8e9a5b6c35ae1311ed2efa9c8e71223c1d35bbe09dc1f097d07547748b8f73aa7170e1b422681cac44d40524ea5e017bc2b730f7581f1d91c9b057adc0
diff --git a/dev-python/sphinxcontrib-newsfeed/metadata.xml b/dev-python/sphinxcontrib-newsfeed/metadata.xml
new file mode 100644
index 000000000000..02be8c5eb78f
--- /dev/null
+++ b/dev-python/sphinxcontrib-newsfeed/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild b/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild
new file mode 100644
index 000000000000..5e23f6a6e333
--- /dev/null
+++ b/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="News Feed extension for Sphinx"
+HOMEPAGE="http://bitbucket.org/prometheus/sphinxcontrib-newsfeed"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ use examples && local EXAMPLES=( demo/. )
+
+ distutils-r1_python_install_all
+}