summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-01 09:40:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-01 09:42:52 +0200
commit879c703a26c0d3af28213068fb54d08c103f4083 (patch)
treed0725b44620654b2d31b7f8862c581134f73bf9a /dev-python/sphinxcontrib-programoutput
parentnet-misc/electrum: Bump to 4.1.0 (diff)
downloadgentoo-879c703a26c0d3af28213068fb54d08c103f4083.tar.gz
gentoo-879c703a26c0d3af28213068fb54d08c103f4083.tar.bz2
gentoo-879c703a26c0d3af28213068fb54d08c103f4083.zip
dev-python/sphinxcontrib-programoutput: Bump to 0.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-programoutput')
-rw-r--r--dev-python/sphinxcontrib-programoutput/Manifest1
-rw-r--r--dev-python/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.17.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-programoutput/Manifest b/dev-python/sphinxcontrib-programoutput/Manifest
index 85d3e5578b3c..4589542c7e98 100644
--- a/dev-python/sphinxcontrib-programoutput/Manifest
+++ b/dev-python/sphinxcontrib-programoutput/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-programoutput-0.16.tar.gz 23714 BLAKE2B 1e5136faa89a2f303008fb0e24f99f544464d30f5c0c072db4e2e25cb30bfc3cd4af6157f6c8dc7ddfaffd8f6587435c5947b6981c34daf2d6029736fdc22870 SHA512 6003b8ce43ed468b01f6bda02c6f58c0518b38c43a75f1ed0869dd8df2ee215310246b7feeba90f213547644c1bdb0164cf1f44f44879ac054dcbd6d6f48a69e
+DIST sphinxcontrib-programoutput-0.17.tar.gz 24067 BLAKE2B 07687a221aa9be1e02629b2961b49eace217631a1298337f77a01986c3c6444a50069a8a8b9c96ca224895ae0f9490158a720519fdf3fb544e9d3e513282eb36 SHA512 cbb564830b8a627de6ecfa83fcc235d7dd7981e191ab3cada66a74d79a5bb2ec0a993eb8ae6249db553dc1814eae98891ea285f2c3cf5e745eabce7b8647b0c4
diff --git a/dev-python/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.17.ebuild b/dev-python/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.17.ebuild
new file mode 100644
index 000000000000..b08129d07d47
--- /dev/null
+++ b/dev-python/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.17.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension to sphinx to include program output"
+HOMEPAGE="
+ https://github.com/NextThought/sphinxcontrib-programoutput/
+ https://pypi.org/project/sphinxcontrib-programoutput/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}