summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-14 10:41:18 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-14 14:26:16 +0200
commit6193a846c20d5d590860556a1e999e3b8e6c4a06 (patch)
tree5a6d044fe21921e00e69dd7c2f8ef35a0570ebca /dev-python/sphinxcontrib-spelling
parentdev-python/funcparserlib: Enable Python 3.7 (diff)
downloadgentoo-6193a846c20d5d590860556a1e999e3b8e6c4a06.tar.gz
gentoo-6193a846c20d5d590860556a1e999e3b8e6c4a06.tar.bz2
gentoo-6193a846c20d5d590860556a1e999e3b8e6c4a06.zip
dev-python/sphinxcontrib-spelling: Bump to 4.3.0, EAPI=7, Py3.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-spelling')
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-4.3.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index 305cf594b9c9..371c991f5875 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1,2 +1,3 @@
DIST sphinxcontrib-spelling-2.1.2.tar.gz 35411 BLAKE2B 9738e18664fb68f6f8f7aafb626b6712f7c30947681f6c5ed288dd76c2b24245cb4083887330fc05ef4fdc64756245d997797ae36899c2c762489fff13219a21 SHA512 993f371e064e8748eb61faae649fb293b154a35955ff84d86fd041f4e2cc4c6e22c686007a67c3b63b0c50fc01ed226708f27db347e58847a46ca733c997d51f
DIST sphinxcontrib-spelling-2.3.0.tar.gz 35687 BLAKE2B 9b48f1953616875bd5f0106ab0a01ac22d176b93eca88da7e36804eaf744aaf6e941d3dcb9f905f9bfe54ea51eb5c0d14d954b3def809994e7ba661e09cdb18e SHA512 194023d2c5ba594a264740a2a45ebd90d37fc17fbd3bc8c53fa303581a652c58332f998a159c9c6c58718dd9898c9b4639e98ee114a2ee1e5f2097e545134a1a
+DIST sphinxcontrib-spelling-4.3.0.tar.gz 38316 BLAKE2B 4bfcbfb22c10b5bd181ef5ba7b64815ccaeaa50f01ccff96adab914cfbe6674ce28088e5eb5717b44531565f961b1f159014d235275065070e22d96d08cd4af2 SHA512 0d1575079be7994df905de02d31ad2c9c3af9634a487fbc9c565067fcbef6c36fd4fbd326ccbee4b40b3ff14696ad85a97c68018a956ff3e2f7e1be46bb3a074
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-4.3.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-4.3.0.ebuild
new file mode 100644
index 000000000000..90e3c702237a
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-4.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="https://github.com/sphinx-contrib/spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${COMMON_DEPEND}
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}