summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-11-09 14:06:52 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-11-17 16:20:50 +0200
commitf267c18536db5eb0cb4a01e0a849ef2da50b9055 (patch)
tree89659356a380d5a77529b719ee30ebd9d9c94da9 /dev-python/spyder-notebook
parentdev-python/spyder-kernels: version bump 1.10.0 (diff)
downloadgentoo-f267c18536db5eb0cb4a01e0a849ef2da50b9055.tar.gz
gentoo-f267c18536db5eb0cb4a01e0a849ef2da50b9055.tar.bz2
gentoo-f267c18536db5eb0cb4a01e0a849ef2da50b9055.zip
dev-python/spyder-notebook: version bump 0.3.1
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/spyder-notebook')
-rw-r--r--dev-python/spyder-notebook/Manifest1
-rw-r--r--dev-python/spyder-notebook/spyder-notebook-0.3.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/spyder-notebook/Manifest b/dev-python/spyder-notebook/Manifest
index 1cddbec043ce..9e82b5409733 100644
--- a/dev-python/spyder-notebook/Manifest
+++ b/dev-python/spyder-notebook/Manifest
@@ -1 +1,2 @@
DIST spyder-notebook-0.3.0.tar.gz 3862097 BLAKE2B 12f9edb3b49373419e491ae3f123b8c325dddefe5a55e8bb853d720aba2c28fbde0be50ec1e5f74198fa1e21faee8a7378218b3e7b3e8378c82be5ee3a10b9b8 SHA512 9259ccfcd79b7d86d49eda74182e3f1e66188f644ca7560a8929dd07c1a453f17bb976ab325ed55df879a00cbc4d14d3724909fb49c56cf1bbf9665ad69b9ec5
+DIST spyder-notebook-0.3.1.tar.gz 3862401 BLAKE2B cfafc631fc0fe44fadecc1f2509435c0a7b6ce5320c19bbe75be92e4c50275a06e79aa77e8b0cf832fbb1fdb229236c3741208f3081e879528751373d8875126 SHA512 253583b0a080f6359b58583f8c459ae858bafe4b15d24e86c7f144801431bd03254ced3984ac98e1e3349f48ebe5081252d298e59dd88609b7bb22f9e0b6765d
diff --git a/dev-python/spyder-notebook/spyder-notebook-0.3.1.ebuild b/dev-python/spyder-notebook/spyder-notebook-0.3.1.ebuild
new file mode 100644
index 000000000000..04a29dcd842c
--- /dev/null
+++ b/dev-python/spyder-notebook/spyder-notebook-0.3.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Jupyter notebook integration with Spyder"
+HOMEPAGE="https://github.com/spyder-ide/spyder-notebook"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/qdarkstyle[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/spyder-4.1.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+DOCS=( "README.md" "RELEASE.md" "CHANGELOG.md" "doc/example.gif" )
+
+# Tests do not work inside virtx/emerge for some reason, core dumped
+RESTRICT="test"
+distutils_enable_tests pytest
+
+python_test() {
+ virtx pytest -vv
+}