summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-01-14 14:54:28 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-02-19 09:02:43 +0200
commit268a30f53ae970eeebb910a0d2e6a924b96ddcb4 (patch)
treee083b9f66255221d365832f91413f50c70b770d1 /dev-python/spyder-unittest
parentdev-python/spyder-notebook: Jupyter notebook integration with Spyder (diff)
downloadgentoo-268a30f53ae970eeebb910a0d2e6a924b96ddcb4.tar.gz
gentoo-268a30f53ae970eeebb910a0d2e6a924b96ddcb4.tar.bz2
gentoo-268a30f53ae970eeebb910a0d2e6a924b96ddcb4.zip
dev-python/spyder-unittest: Plugin to run tests and view the results
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/spyder-unittest')
-rw-r--r--dev-python/spyder-unittest/Manifest1
-rw-r--r--dev-python/spyder-unittest/metadata.xml12
-rw-r--r--dev-python/spyder-unittest/spyder-unittest-0.4.0.ebuild38
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/spyder-unittest/Manifest b/dev-python/spyder-unittest/Manifest
new file mode 100644
index 000000000000..f00c3c77ddda
--- /dev/null
+++ b/dev-python/spyder-unittest/Manifest
@@ -0,0 +1 @@
+DIST spyder-unittest-0.4.0.tar.gz 74408 BLAKE2B d1d8d3b331fefda5c918deb811052518109592919bce07006b49a533f85bc82e8a6efcb0eb4c9b799ef736eb1a5744bd637fdc1bf4f123b0ad5d742ca9c41027 SHA512 fe402b19bb7c2350cd27d1b5786840ed10736db042ee0b630d29a78aaee1e6cdfb3588eb8bd9bf9e124fdcaaab253e0c67e75480d26f41a16f678a7176db53d0
diff --git a/dev-python/spyder-unittest/metadata.xml b/dev-python/spyder-unittest/metadata.xml
new file mode 100644
index 000000000000..8fc11184ab00
--- /dev/null
+++ b/dev-python/spyder-unittest/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/spyder-unittest/spyder-unittest-0.4.0.ebuild b/dev-python/spyder-unittest/spyder-unittest-0.4.0.ebuild
new file mode 100644
index 000000000000..e13f6bbc8f2f
--- /dev/null
+++ b/dev-python/spyder-unittest/spyder-unittest-0.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin for Spyder to run tests and view the results"
+HOMEPAGE="https://github.com/spyder-ide/spyder-unittest"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/spyder-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ spyder_unittest_test() {
+ # fails to test in ${BUILDIR}/lib
+ # test do work if executed directly in the extracted tarball
+ local PYTHONPATH="${WORKDIR}/${P}"
+ pytest -vv spyder_unittest/tests spyder_unittest/widgets/tests
+ }
+
+ virtx spyder_unittest_test
+}