summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-05-02 02:26:54 -0700
committerZac Medico <zmedico@gentoo.org>2016-05-02 02:31:35 -0700
commit8abfc83beeba0c7f238216357e2ae676477be9a6 (patch)
treeaff16214a4df4dff3641e53480f41e43844cb5fa /dev-python/sqlalchemy-rqlite/sqlalchemy-rqlite-9999.ebuild
parentmail-client/mutt: version bump to 1.6.1 (diff)
downloadgentoo-8abfc83beeba0c7f238216357e2ae676477be9a6.tar.gz
gentoo-8abfc83beeba0c7f238216357e2ae676477be9a6.tar.bz2
gentoo-8abfc83beeba0c7f238216357e2ae676477be9a6.zip
dev-python/sqlalchemy-rqlite: new package
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/sqlalchemy-rqlite/sqlalchemy-rqlite-9999.ebuild')
-rw-r--r--dev-python/sqlalchemy-rqlite/sqlalchemy-rqlite-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sqlalchemy-rqlite/sqlalchemy-rqlite-9999.ebuild b/dev-python/sqlalchemy-rqlite/sqlalchemy-rqlite-9999.ebuild
new file mode 100644
index 000000000000..c7e243cce471
--- /dev/null
+++ b/dev-python/sqlalchemy-rqlite/sqlalchemy-rqlite-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+fi
+
+DESCRIPTION="A SQLAlchemy dialect for rqlite"
+EGIT_REPO_URI="https://github.com/rqlite/sqlalchemy-rqlite.git"
+HOMEPAGE="${EGIT_REPO_URI%.git}/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pyrqlite[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+ )"
+
+src_prepare() {
+ sed -e "s:^__version__ = .*:__version__ = '${PV}':" -i src/sqlalchemy_rqlite/constants.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ esetup.py test || die "tests failed"
+ esetup.py lint -f text -E || die "pylint failed"
+}