summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-15 21:22:32 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-15 21:22:32 -0600
commited782808d24cc2131aa8993886b7a1857920b58d (patch)
treefcf50da109c77ee59842e07aa49740b233afb7b8 /dev-python/sqlalchemy
parentdev-python/configparser: readd missing arm64 keyword (diff)
downloadgentoo-ed782808d24cc2131aa8993886b7a1857920b58d.tar.gz
gentoo-ed782808d24cc2131aa8993886b7a1857920b58d.tar.bz2
gentoo-ed782808d24cc2131aa8993886b7a1857920b58d.zip
dev-python/sqlalchemy: 1.2.2 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/sqlalchemy')
-rw-r--r--dev-python/sqlalchemy/Manifest1
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.2.2.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/sqlalchemy/Manifest b/dev-python/sqlalchemy/Manifest
index 57305e5bff58..d3bb7f60352c 100644
--- a/dev-python/sqlalchemy/Manifest
+++ b/dev-python/sqlalchemy/Manifest
@@ -4,3 +4,4 @@ DIST SQLAlchemy-1.0.17.tar.gz 4787165 BLAKE2B b00ead35149cfd7eab3476e29aa2b2b79e
DIST SQLAlchemy-1.0.19.tar.gz 4788659 BLAKE2B 813bc2148fd080762ea7748d9878500afac4148dc186a34172321fd97333eb6c8632ae3b05b2e8b187a3660ae34a426062ade56297b693d367eeea2c3966b249 SHA512 57d51fecb40e349b05da027bf39375a81c1d98e6d47f4dd076b9c7e2e3c8b6bdf8317e7b3e88c015cbd0d7858324ba0499a21a8ac39568c9ec95326e02af97bb
DIST SQLAlchemy-1.1.12.tar.gz 5178158 BLAKE2B 92455943f3e5ce8c87fc9dd21da7c5ea54a9292fe2a3a319a8a9c8d54cd103193935d567326b8632d2fcd94664ef91cd1a3d621008bec684ba35ff73691ff01e SHA512 f9d14b3d4eab049e9d7377008cf11678c1413e204baad898093282d1812d242a544bbb6606b4e9a83b37d5c17bcec3c115ffe402dda8b6a84d0d5186415645e3
DIST SQLAlchemy-1.2.0.tar.gz 5451303 BLAKE2B 273edad173583d47d6ebdb4d3efddddb6e8e6c1e333667d71a1befb0aabc7ff8231f926c18d5463e1d4b815d2b2f39b7c9bca03ab3bf0f91f039b7ea55071e28 SHA512 0d9e57147b022955ad20da5b280e8734ba4be9585301b6e8fb9b96797d87d8707f95cb58afbaf310ec8033defffc4d794bec1d5089ca016b8dd9497e292881e3
+DIST SQLAlchemy-1.2.2.tar.gz 5460157 BLAKE2B 60c5066a2993d9878f5d3abec1a6a9a4d0a3dc5878df71baee895e5278b95696b775e16000da0ba4c2c358b0a90e70faff0b5733a4f00255b0ec0d605cdd07c6 SHA512 060ce803b8b621d51aa69100c598c424c36f051bdce1e2df3f4d837815f91cb55c4e089db5375b01832ec28bf42332311009c51c1b5e7aae92aea001ee880db5
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.2.2.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.2.2.ebuild
new file mode 100644
index 000000000000..3c3f17ea7ae4
--- /dev/null
+++ b/dev-python/sqlalchemy/sqlalchemy-1.2.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="sqlite?"
+
+inherit distutils-r1 eutils flag-o-matic
+
+MY_PN="SQLAlchemy"
+MY_P="${MY_PN}-${PV/_beta/b}"
+
+DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
+HOMEPAGE="http://www.sqlalchemy.org/ https://pypi.python.org/pypi/SQLAlchemy"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="doc examples +sqlite test"
+
+REQUIRED_USE="test? ( sqlite )"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Disable tests hardcoding function call counts specific to Python versions.
+ rm -r test/aaa_profiling || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ # Create copies of necessary files in BUILD_DIR.
+ # https://bitbucket.org/zzzeek/sqlalchemy/issue/3144/
+ cp -pR examples sqla_nose.py setup.cfg test "${BUILD_DIR}" || die
+ pushd "${BUILD_DIR}" > /dev/null || die
+ if [[ "${EPYTHON}" == "python3.2" ]]; then
+ 2to3 --no-diffs -w test || die
+ fi
+ # Recently upstream elected to make the testsuite also pytest capable
+ # "${PYTHON}" sqla_nose.py || die "Testsuite failed under ${EPYTHON}"
+ py.test --verbose test || die "Testsuite failed under ${EPYTHON}"
+ popd > /dev/null
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/. )
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "MySQL support" dev-python/mysql-python dev-python/mysql-connector-python
+ optfeature "mssql support" dev-python/pymssql
+ optfeature "postgresql support" dev-python/psycopg:2
+}