summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/sqlitecachec
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/sqlitecachec')
-rw-r--r--dev-python/sqlitecachec/Manifest1
-rw-r--r--dev-python/sqlitecachec/metadata.xml5
-rw-r--r--dev-python/sqlitecachec/sqlitecachec-1.1.4-r1.ebuild30
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sqlitecachec/Manifest b/dev-python/sqlitecachec/Manifest
new file mode 100644
index 000000000000..86ed6277a621
--- /dev/null
+++ b/dev-python/sqlitecachec/Manifest
@@ -0,0 +1 @@
+DIST yum-metadata-parser-1.1.4.tar.gz 16469 SHA256 f1560a284541feb720c3ae35b6b31f80c2be5cb9ca86b3a1ee9459846f821ada SHA512 51c1c3652171713a6decc165a4f8c4ddb5641f2ad3ee9b84fba3514d5c9afbb0c7ebc7dbb26156194b58c29227ef7b8d40ad760082da1c568254bcbee129d68c WHIRLPOOL ae479b4f93f605b0f19ec7f1c729cac2e19af408e46568209be711aae22b1296b45f77b0eb5309ff855545fdc323dcd64899541156a9f0079ab6afd504b1eb4c
diff --git a/dev-python/sqlitecachec/metadata.xml b/dev-python/sqlitecachec/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/sqlitecachec/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/sqlitecachec/sqlitecachec-1.1.4-r1.ebuild b/dev-python/sqlitecachec/sqlitecachec-1.1.4-r1.ebuild
new file mode 100644
index 000000000000..6cb096a0d2ec
--- /dev/null
+++ b/dev-python/sqlitecachec/sqlitecachec-1.1.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P="yum-metadata-parser-${PV}"
+
+DESCRIPTION="sqlite cacher for python applications"
+HOMEPAGE="http://yum.baseurl.org/"
+SRC_URI="http://yum.baseurl.org/download/yum-metadata-parser/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+# glib and libxml2 are used via an extension module written in C.
+# No need to add PYTHON_USEDEP here.
+RDEPEND="dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"