summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/squaremap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/squaremap')
-rw-r--r--dev-python/squaremap/Manifest2
-rw-r--r--dev-python/squaremap/metadata.xml12
-rw-r--r--dev-python/squaremap/squaremap-1.0.3.ebuild27
-rw-r--r--dev-python/squaremap/squaremap-1.0.4.ebuild27
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/squaremap/Manifest b/dev-python/squaremap/Manifest
new file mode 100644
index 000000000000..4127c6a81fe8
--- /dev/null
+++ b/dev-python/squaremap/Manifest
@@ -0,0 +1,2 @@
+DIST SquareMap-1.0.3.tar.gz 7433 SHA256 d56f4d6db4b49a03d66dcdc844507684eacb9f9a5a4b7874753808a158bd82a8 SHA512 a106bb61d5e8b54691b6ea80fc7d3e202346f6ea0a0323a8f3bae3accd9b6fe4f280e2dc4c9ce5b5333c0c0c32f295f3021ed240fa540d4669dd83e31a7dbf48 WHIRLPOOL 266f4eec61c9b83b2c262d3dcdcde0bfb9c4c2805c326c5ab6c21cefee61968f98d16595d3fe64dcaeb208af5bdba1fc2d246fce4ebb6deb46f7c2f9d8c9bc9d
+DIST SquareMap-1.0.4.tar.gz 7439 SHA256 feab6cb3b222993df68440e34825d8a16de2c74fdb290ae3974c86b1d5f3eef8 SHA512 d01e61697571360b58e762787237bb8533b3de238f26323380a8b0b90d72d2f00e2a43e7f6742fbbb3483573493b0d83568e0651cbf9bdd463b911d09bf27e76 WHIRLPOOL 482682b6aff35cbe3c3605266f9b08ba5f4e6fdf8bf41a31843d04a5b280976e8144e61f1e23ce6aa376af9b14658f687e7b89bec77414aed3817a9a53b2a0f5
diff --git a/dev-python/squaremap/metadata.xml b/dev-python/squaremap/metadata.xml
new file mode 100644
index 000000000000..7ca81b3ec348
--- /dev/null
+++ b/dev-python/squaremap/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>swegener@gentoo.org</email>
+ <name>Sven Wegener</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">SquareMap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/squaremap/squaremap-1.0.3.ebuild b/dev-python/squaremap/squaremap-1.0.3.ebuild
new file mode 100644
index 000000000000..fe5906092f2a
--- /dev/null
+++ b/dev-python/squaremap/squaremap-1.0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_PN="SquareMap"
+MY_P="${MY_PN}-${PV/_beta/b}"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Hierarchic data-visualisation control for wxPython"
+HOMEPAGE="http://pypi.python.org/pypi/SquareMap"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ <dev-python/wxpython-3"
+
+S="${WORKDIR}"/${MY_P}
diff --git a/dev-python/squaremap/squaremap-1.0.4.ebuild b/dev-python/squaremap/squaremap-1.0.4.ebuild
new file mode 100644
index 000000000000..883695b1147d
--- /dev/null
+++ b/dev-python/squaremap/squaremap-1.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_PN="SquareMap"
+MY_P="${MY_PN}-${PV/_beta/b}"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Hierarchic data-visualisation control for wxPython"
+HOMEPAGE="http://pypi.python.org/pypi/SquareMap"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/wxpython"
+
+S="${WORKDIR}"/${MY_P}