summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2020-12-02 20:55:13 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2020-12-02 20:55:13 -0500
commit203d995ae300e370d2e8cac9dab94d98ffe58670 (patch)
treee5880dbeb46bd3f6dd5b7cc6f5112abc52320842 /dev-python/sshtunnel
parentdev-python/fleep: add py3_{8,9} (diff)
downloadgentoo-203d995ae300e370d2e8cac9dab94d98ffe58670.tar.gz
gentoo-203d995ae300e370d2e8cac9dab94d98ffe58670.tar.bz2
gentoo-203d995ae300e370d2e8cac9dab94d98ffe58670.zip
dev-python/sshtunnel: Bump to 0.3.1
Bug: https://bugs.gentoo.org/746779 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-python/sshtunnel')
-rw-r--r--dev-python/sshtunnel/Manifest1
-rw-r--r--dev-python/sshtunnel/sshtunnel-0.3.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/sshtunnel/Manifest b/dev-python/sshtunnel/Manifest
index 0f0208aa5d1b..135312938def 100644
--- a/dev-python/sshtunnel/Manifest
+++ b/dev-python/sshtunnel/Manifest
@@ -1,2 +1,3 @@
DIST sshtunnel-0.1.4.tar.gz 48330 BLAKE2B 5fdc5dd602274a16025f250fcc3a36453a17c921f51367cac0cb0ef36be6251f687b53b1df6072d1e32456a5c0fa5ec6d2fd8e5d4874977a641a6c9ba81ac57c SHA512 c228fe79cf5172c950777a40b27ababd42a31b7aad8a8472d55a2b3babf5aa4c5308799bb271f33f0e943c309eb9adedee321045a03324cb5e30a385178751ca
DIST sshtunnel-0.1.5.tar.gz 49345 BLAKE2B dde497296ebf84cd34a485ac82de3ca138671b4b8ad2d2307a5e40dc0bb9c6a6daa8c8f3888db942133a9a0fb5321c240c5f2db7c93baf824c9cefaf361ef7c9 SHA512 ae804865a83bae8443cff1a73b168ffb8aac0c5c4fa6c7a5e142f4f95b4eef34bc7674588fa8797fa35b2685016828bcb137f4102e84ea15089671cf64503d17
+DIST sshtunnel-0.3.1.tar.gz 51392 BLAKE2B 9cf5c0e1f12489e482abf73e74d1a59bdc619b5248265add15744357ef49bf502e013b9d4494efff27e45817e0728f2cee3629f5cf21ba9849f564e84ac9c4a9 SHA512 5c24243cae959cf38f2cdcad4351950ca3abd1c6d289829b6603cd8e93b8d61480c4c7b3607bb38615854825c0bf08890c2362f79104c8bae7f9bf8e0931aa85
diff --git a/dev-python/sshtunnel/sshtunnel-0.3.1.ebuild b/dev-python/sshtunnel/sshtunnel-0.3.1.ebuild
new file mode 100644
index 000000000000..2f97b87074f3
--- /dev/null
+++ b/dev-python/sshtunnel/sshtunnel-0.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Pure Python SSH tunnels"
+HOMEPAGE="https://pypi.org/project/sshtunnel/"
+SRC_URI="mirror://pypi/s/sshtunnel/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+IUSE=""
+
+RDEPEND="dev-python/paramiko[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"