summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-01-04 15:30:42 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-04 16:07:54 +0100
commitce2f044cc673a6d08cd8a40459bd0dbf66df864e (patch)
tree1fdec06084174c0aed9bc442a87b042354b402e9 /dev-python/stapler/stapler-0.4_p20160424.ebuild
parentmail-client/thunderbird: cleanup old (diff)
downloadgentoo-ce2f044cc673a6d08cd8a40459bd0dbf66df864e.tar.gz
gentoo-ce2f044cc673a6d08cd8a40459bd0dbf66df864e.tar.bz2
gentoo-ce2f044cc673a6d08cd8a40459bd0dbf66df864e.zip
dev-python/stapler: new ebuild.
stapler is a suite of tools for PDF files manipulation. It makes use of the PyPDF2 library to provide a (somewhat) lighter alternative to pdftk. See https://github.com/hellerbarde/stapler. Bug: https://bugs.gentoo.org/562568 Package-Manager: Portage-2.3.13, Repoman-2.3.3 Reviewed-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-python/stapler/stapler-0.4_p20160424.ebuild')
-rw-r--r--dev-python/stapler/stapler-0.4_p20160424.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/stapler/stapler-0.4_p20160424.ebuild b/dev-python/stapler/stapler-0.4_p20160424.ebuild
new file mode 100644
index 000000000000..3cc72cc1cabb
--- /dev/null
+++ b/dev-python/stapler/stapler-0.4_p20160424.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+# Commit Date: 26th Apr 2016
+COMMIT="7c153e6a8f52573ff886ebf0786b64e17699443a"
+
+DESCRIPTION="Suite of tools for PDF files manipulation written in Python"
+HOMEPAGE="https://github.com/hellerbarde/stapler"
+SRC_URI="https://github.com/hellerbarde/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}-${COMMIT}"