summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2017-11-09 06:51:32 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-16 23:16:10 +0100
commit19197c865d38526aae5302e7e26b44b1ad47d9a1 (patch)
tree0b903c0a3f1889afb7494135ba5072f9a7931620 /dev-python/statsmodels/statsmodels-9999.ebuild
parentsci-geosciences/opencpn: improve wxwidgets eclass usage (diff)
downloadgentoo-19197c865d38526aae5302e7e26b44b1ad47d9a1.tar.gz
gentoo-19197c865d38526aae5302e7e26b44b1ad47d9a1.tar.bz2
gentoo-19197c865d38526aae5302e7e26b44b1ad47d9a1.zip
dev-python/statsmodels: live ebuild
Closes: https://github.com/gentoo/gentoo/pull/6155 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-python/statsmodels/statsmodels-9999.ebuild')
-rw-r--r--dev-python/statsmodels/statsmodels-9999.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/statsmodels/statsmodels-9999.ebuild b/dev-python/statsmodels/statsmodels-9999.ebuild
new file mode 100644
index 000000000000..d0a074fec050
--- /dev/null
+++ b/dev-python/statsmodels/statsmodels-9999.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 git-r3 virtualx
+
+DESCRIPTION="Statistical computations and models for use with SciPy"
+HOMEPAGE="http://www.statsmodels.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/statsmodels/statsmodels.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc examples test"
+
+CDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+RDEPEND="${CDEPEND}
+ examples? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
+"
+DEPEND="${CDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "/sphinx.ext.intersphinx/d" -i docs/source/conf.py || die
+ export VARTEXFONTS="${T}"/fonts
+ export MPLCONFIGDIR="${T}"
+ export HOME="${T}"
+ echo "backend : Agg" > "${MPLCONFIGDIR}"/matplotlibrc || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx -b html --build-dir=docs/build
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ virtx nosetests -v || die
+}
+
+python_install_all() {
+ find "${S}" -name \*LICENSE.txt -delete
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Plotting functionality" "dev-python/matplotlib"
+}