summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-26 19:40:42 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-26 23:24:05 -0500
commit33c258ee4f16f78ce787a5eccb00dbcec3dec7fb (patch)
tree3102b706ca9d8a0140d418630576e83d06e21819 /dev-python/stevedore
parentdev-python/oslo-sphinx: 4.15.1 bup (diff)
downloadgentoo-33c258ee4f16f78ce787a5eccb00dbcec3dec7fb.tar.gz
gentoo-33c258ee4f16f78ce787a5eccb00dbcec3dec7fb.tar.bz2
gentoo-33c258ee4f16f78ce787a5eccb00dbcec3dec7fb.zip
dev-python/stevedore: 1.25.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/stevedore')
-rw-r--r--dev-python/stevedore/Manifest1
-rw-r--r--dev-python/stevedore/stevedore-1.25.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/stevedore/Manifest b/dev-python/stevedore/Manifest
index bc5db16c3a6b..be8a21e280d0 100644
--- a/dev-python/stevedore/Manifest
+++ b/dev-python/stevedore/Manifest
@@ -1 +1,2 @@
DIST stevedore-1.20.1.tar.gz 505908 SHA256 046200a915780b58bf1c84436e86701b741d664893aefa84d8aceadd15ed4734 SHA512 7518fb4cac2ea15867a616373521169fd114152ae7e657deb26dbcf874f2442336824ded480973b4334e9b56c349abd165aab7779defc219f57d7ba7f670048c WHIRLPOOL e67a89733def07e8425750d9bc742388de83f8cb13d95dd0001fba4136449e74c465b847a7218df423633d311f0af0003eda8087eb0a4e071ab4d2e78949fca7
+DIST stevedore-1.25.0.tar.gz 505985 SHA256 c8a373b90487b7a1b52ebaa3ca5059315bf68d9ebe15b2203c2fa675bd7e1e7e SHA512 d0e01312e75f7166c49bc4b57f5ea54492f6bbb0dbb02ae8cd50ce4e4ba4e71db936715f3076c49e554d9f6cc87a5b0166a1814072c56d69950fb9b6cbecf05c WHIRLPOOL 62454f1b1d349f30d0ce5a0324261e42497a821803491c082b1c4ed4266cdd151b11e0584f1add4e7dd4b50ab83f3991beacc03393d5e7ffa4ea303ae760b869
diff --git a/dev-python/stevedore/stevedore-1.25.0.ebuild b/dev-python/stevedore/stevedore-1.25.0.ebuild
new file mode 100644
index 000000000000..19d8e05bf53e
--- /dev/null
+++ b/dev-python/stevedore/stevedore-1.25.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/openstack/stevedore https://pypi.python.org/pypi/stevedore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/pillow-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Delete spurious data in requirements.txt
+ sed -e '/^pbr/d' -i requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ nosetests --verbosity=3 stevedore || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}