summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-12-21 01:10:45 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-12-21 01:12:57 -0600
commit7137d49f1f1d89bc3e71feae9d66e1e0e5356678 (patch)
tree26b446edce607ab42438452e11108bf1546e615c /dev-python/stevedore
parentdev-python/futurist: 1.3.1 stable amd64 and x86 with cleanup (diff)
downloadgentoo-7137d49f1f1d89bc3e71feae9d66e1e0e5356678.tar.gz
gentoo-7137d49f1f1d89bc3e71feae9d66e1e0e5356678.tar.bz2
gentoo-7137d49f1f1d89bc3e71feae9d66e1e0e5356678.zip
dev-python/stevedore: 1.25.1 stable amd64 and x86 with cleanup
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-python/stevedore')
-rw-r--r--dev-python/stevedore/Manifest1
-rw-r--r--dev-python/stevedore/stevedore-1.25.0.ebuild63
-rw-r--r--dev-python/stevedore/stevedore-1.25.1.ebuild2
3 files changed, 1 insertions, 65 deletions
diff --git a/dev-python/stevedore/Manifest b/dev-python/stevedore/Manifest
index 6a8bf94da600..a9cf77fca652 100644
--- a/dev-python/stevedore/Manifest
+++ b/dev-python/stevedore/Manifest
@@ -1,3 +1,2 @@
DIST stevedore-1.20.1.tar.gz 505908 BLAKE2B e12891088b3b55ea0376565da51b14f23bee27ae08b9f85817333b5c6e279c58b7e2cea87779ec527cb10eb1613fed55733755842028e598f3392431b70b5b48 SHA512 7518fb4cac2ea15867a616373521169fd114152ae7e657deb26dbcf874f2442336824ded480973b4334e9b56c349abd165aab7779defc219f57d7ba7f670048c
-DIST stevedore-1.25.0.tar.gz 505985 BLAKE2B 471d76e1d16392626cdfd1fdce3939d2891344e1d5332bf1cc0c3cd877f2a28ddfa6fb5870a316a188413d439b0f3b43dd24bd1c4b6ff40908a8bec52ada85fd SHA512 d0e01312e75f7166c49bc4b57f5ea54492f6bbb0dbb02ae8cd50ce4e4ba4e71db936715f3076c49e554d9f6cc87a5b0166a1814072c56d69950fb9b6cbecf05c
DIST stevedore-1.25.1.tar.gz 509014 BLAKE2B 22580ac0e5af56eadd81e7521888e3b2458a1c03a3bdac69df1f2eeef20248f1ddc1748447e3e961b61cbe62ebc939e36c04ff011b7845b3278e18a5fdc9e14e SHA512 f3d2a7360e783c800c3c2488f6adf6f9f76e34e4a4e6f3fc53d2f1114b889c443c13fdf217ddce65a41922dda2c782f19b2077847807c70e732a522fd2166ff0
diff --git a/dev-python/stevedore/stevedore-1.25.0.ebuild b/dev-python/stevedore/stevedore-1.25.0.ebuild
deleted file mode 100644
index 6b0288917a58..000000000000
--- a/dev-python/stevedore/stevedore-1.25.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/openstack/stevedore https://pypi.python.org/pypi/stevedore"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc test"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
- !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/pillow-2.4.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.11.0[${PYTHON_USEDEP}]
- >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
- !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # Delete spurious data in requirements.txt
- sed -e '/^pbr/d' -i requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- nosetests --verbosity=3 stevedore || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/stevedore/stevedore-1.25.1.ebuild b/dev-python/stevedore/stevedore-1.25.1.ebuild
index c26032f9df73..8a34d764c358 100644
--- a/dev-python/stevedore/stevedore-1.25.1.ebuild
+++ b/dev-python/stevedore/stevedore-1.25.1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm64 x86"
IUSE="doc test"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]