summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-11-07 10:49:46 -0800
committerZac Medico <zmedico@gentoo.org>2017-11-07 11:03:02 -0800
commitfaf200a2246623dbba5eb2d805df8c03818a719c (patch)
tree7e49fc3e7bd3b41accfc17c20f1622997ae8bf81 /dev-python/tabulate/tabulate-0.8.1.ebuild
parentdev-python/clang-python: Enable python3 (diff)
downloadgentoo-faf200a2246623dbba5eb2d805df8c03818a719c.tar.gz
gentoo-faf200a2246623dbba5eb2d805df8c03818a719c.tar.bz2
gentoo-faf200a2246623dbba5eb2d805df8c03818a719c.zip
dev-python/tabulate: version bump to 0.8.1
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python/tabulate/tabulate-0.8.1.ebuild')
-rw-r--r--dev-python/tabulate/tabulate-0.8.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/tabulate/tabulate-0.8.1.ebuild b/dev-python/tabulate/tabulate-0.8.1.ebuild
new file mode 100644
index 000000000000..a91800179602
--- /dev/null
+++ b/dev-python/tabulate/tabulate-0.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pretty-print tabular data"
+HOMEPAGE="https://pypi.python.org/pypi/tabulate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( virtual/python-funcsigs[${PYTHON_USEDEP}] )
+"
+
+# Missing something in tarball
+#
+# from common import assert_equal
+RESTRICT=test
+
+python_test() {
+ local testcase
+ for testcase in test/*py; do
+ ${PYTHON} ${testcase} || die
+ done
+}