summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-08 08:13:15 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-08 08:21:17 +0200
commit3110b8add0ad27a40ff284039c7c6e15ce029d56 (patch)
treef15bd71fab5cbca8210f765de286d5be058eea22 /dev-python/tempora
parentdev-python/portend: Bump to 3.0.0 (diff)
downloadgentoo-3110b8add0ad27a40ff284039c7c6e15ce029d56.tar.gz
gentoo-3110b8add0ad27a40ff284039c7c6e15ce029d56.tar.bz2
gentoo-3110b8add0ad27a40ff284039c7c6e15ce029d56.zip
dev-python/tempora: Bump to 4.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tempora')
-rw-r--r--dev-python/tempora/Manifest1
-rw-r--r--dev-python/tempora/tempora-4.1.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/tempora/Manifest b/dev-python/tempora/Manifest
index dda6e0df6d3d..04e8b2481d19 100644
--- a/dev-python/tempora/Manifest
+++ b/dev-python/tempora/Manifest
@@ -1 +1,2 @@
DIST tempora-4.1.1.tar.gz 19208 BLAKE2B 77901d1f4b19f2c88d4492788f8b351c70ffdb474769597bc2eefc85b4dd503e57876b687b600b49a381dd24133ae30ac547961e7cf8d7005e4cce5dc5049012 SHA512 a272980be5d4448bbd97d9e48d8a992c07cd1e970924f301fd3444834fe112453d5714ff8f3e7af6a5775d931b825601d7f1abf3cd9319b08d148a2a07d40d07
+DIST tempora-4.1.2.tar.gz 19243 BLAKE2B 4014fce1abf24231c79bfa80db7ecf80303bca43902aa68a880c3e0a29cb9d6f7bd1d9e02c4f93d43db2a7810f0fd7a26de31383057dcf63b5b8a42fe8e6810e SHA512 dc03db61af973645f8f89c13eb1a0b696275a7a2768f82cd61d1602891d4bb0d4b45725404f39da242362346eb0dc6c38892a117f150f32517a2ac8d3436f5db
diff --git a/dev-python/tempora/tempora-4.1.2.ebuild b/dev-python/tempora/tempora-4.1.2.ebuild
new file mode 100644
index 000000000000..c187f41d73e5
--- /dev/null
+++ b/dev-python/tempora/tempora-4.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Objects and routines pertaining to date and time"
+HOMEPAGE="https://github.com/jaraco/tempora"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"