summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-25 21:41:44 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-25 21:54:12 +0100
commit80bb5d9e4fdacd527511c89c9b08b0fb38cae1fb (patch)
tree8f44a6ef030321fb6c87865d4fc0c30595a124bb /dev-python/testfixtures
parentdev-python/django-tagging: Remove Python 2 (diff)
downloadgentoo-80bb5d9e4fdacd527511c89c9b08b0fb38cae1fb.tar.gz
gentoo-80bb5d9e4fdacd527511c89c9b08b0fb38cae1fb.tar.bz2
gentoo-80bb5d9e4fdacd527511c89c9b08b0fb38cae1fb.zip
dev-python/testfixtures: Remove Python 2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/testfixtures-4.9.1.ebuild4
-rw-r--r--dev-python/testfixtures/testfixtures-6.8.2.ebuild4
2 files changed, 2 insertions, 6 deletions
diff --git a/dev-python/testfixtures/testfixtures-4.9.1.ebuild b/dev-python/testfixtures/testfixtures-4.9.1.ebuild
index 7c2dbd6ada6a..60bd10d75f5f 100644
--- a/dev-python/testfixtures/testfixtures-4.9.1.ebuild
+++ b/dev-python/testfixtures/testfixtures-4.9.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
@@ -21,14 +21,12 @@ DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pkginfo[${PYTHON_USEDEP}]' python2_7 pypy )
)
test? (
dev-python/manuel[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/nose-cover3[${PYTHON_USEDEP}]
dev-python/nose_fixes[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
)"
python_prepare_all() {
diff --git a/dev-python/testfixtures/testfixtures-6.8.2.ebuild b/dev-python/testfixtures/testfixtures-6.8.2.ebuild
index a3b4728a12a9..a827aad44dd2 100644
--- a/dev-python/testfixtures/testfixtures-6.8.2.ebuild
+++ b/dev-python/testfixtures/testfixtures-6.8.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -21,11 +21,9 @@ DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pkginfo[${PYTHON_USEDEP}]' python2_7 pypy )
)
test? (
dev-python/django[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-django[${PYTHON_USEDEP}]
dev-python/sybil[${PYTHON_USEDEP}]