summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:36:07 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:36:07 +0100
commit1fb45205d6631eacbab9163a0b0fd5c86cdc1509 (patch)
tree20a86621b5abbd55e440083f8bb693646ac3a9d5 /dev-python/testpath/testpath-0.2.ebuild
parentdev-python/jupyter: Import from science overlay (diff)
downloadgentoo-1fb45205d6631eacbab9163a0b0fd5c86cdc1509.tar.gz
gentoo-1fb45205d6631eacbab9163a0b0fd5c86cdc1509.tar.bz2
gentoo-1fb45205d6631eacbab9163a0b0fd5c86cdc1509.zip
dev-python/testpath: Import from science overlay
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/testpath/testpath-0.2.ebuild')
-rw-r--r--dev-python/testpath/testpath-0.2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/testpath/testpath-0.2.ebuild b/dev-python/testpath/testpath-0.2.ebuild
new file mode 100644
index 000000000000..a3ee76529f4a
--- /dev/null
+++ b/dev-python/testpath/testpath-0.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test utilities for code working with files and commands"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+
+PATCHES=(
+ "${FILESDIR}/${P}"-setup.py.patch
+ )
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
+ fi
+
+distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+ }
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
+ py.test || die
+}