summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-15 16:38:56 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-15 16:41:21 +0200
commit33fee5760889f67afc0a2cc10eef0a7218a4a112 (patch)
treeb897500e2ed917df506dc76159c743363244b685 /dev-python/testrepository
parentdev-python/logilab-common: Version Bump (diff)
downloadgentoo-33fee5760889f67afc0a2cc10eef0a7218a4a112.tar.gz
gentoo-33fee5760889f67afc0a2cc10eef0a7218a4a112.tar.bz2
gentoo-33fee5760889f67afc0a2cc10eef0a7218a4a112.zip
dev-python/testrepository: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/testrepository')
-rw-r--r--dev-python/testrepository/Manifest1
-rw-r--r--dev-python/testrepository/testrepository-0.0.20.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/testrepository/Manifest b/dev-python/testrepository/Manifest
index c040589a9fc9..c43948ed69c9 100644
--- a/dev-python/testrepository/Manifest
+++ b/dev-python/testrepository/Manifest
@@ -1,2 +1,3 @@
DIST testrepository-0.0.17.tar.gz 84255 SHA256 70b70e0ba6aacb44036ed5dcbdbe36008816fc7098c2e3e4891734fc09ecd36e SHA512 c5b7a0a0b6494166f85be86a85821d36922e754e02a487605b5e6cf2ae52ff1f9c37b48bd07f7acc1d9dc9450fcf17311f5ffb6bb8bd31d7a26f5c53de88f94d WHIRLPOOL 0fe9a003af396462d9aa73a73da2f0253fd247e4025ae9dc0047e3fdf02d872189eaf96416750206612419d048eeeb49699a54c6cf1b95fa66cc444b5fbd05fe
DIST testrepository-0.0.18.tar.gz 84886 SHA256 ba15301c6ec6bf1b8e0dad10ac7313b11e17ceb8d28ec4a3625c9aaa766727fd SHA512 4e90db6364f77f464ae063020b016367529588f581af001c2564bf4babb264fc37bb7231413725211c6d483a269360d86201f81d2b24d7eb162dca2463d13c92 WHIRLPOOL c6ced39884ea731173b59a0cbd283d474b3a658e94e2f94a87b5b5e8461d82790cfda2d3e834d51e90b6e57299163cf2dc9ef2cb62440104ac6a046039196abb
+DIST testrepository-0.0.20.tar.gz 84956 SHA256 752449bc98c20253ec4611c40564aea93d435a5bf3ff672208e01cc10e5858eb SHA512 df14500e2b27b6f39d9d4c4f42961efd63dfe25186e561eb1678952a8ab9311f17c36b78819fea33e0ac879c47a33d45c31ff58be017609c8a6157905ee712d6 WHIRLPOOL 12be50a78a79b0c1aa43d4a2c97055a3956f85653e36ab56a9eedc0c2f80bf0860b702e62627055a72e9ddfe9812bd916e4c4adbe50df02bd94b911b9c0b7d0c
diff --git a/dev-python/testrepository/testrepository-0.0.20.ebuild b/dev-python/testrepository/testrepository-0.0.20.ebuild
new file mode 100644
index 000000000000..ae10b32407ea
--- /dev/null
+++ b/dev-python/testrepository/testrepository-0.0.20.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A repository of test results"
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]"
+#bzr is listed but presumably req'd for a live repo test run
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/testresources[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+# Required for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ # some errors appear to have crept in the suite undert py3 since addition.
+ # Python2.7 now passes all.
+
+ esetup.py testr
+}