summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-11 09:09:34 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-11 09:53:18 +0200
commitac6755b2fdfe094c5bc18d97b973f4128e2d5d3a (patch)
tree5941ab616fae7796e347806495bbb56820252531 /dev-python/testrepository
parentdev-python/stormpath: Drop unncessary die (diff)
downloadgentoo-ac6755b2fdfe094c5bc18d97b973f4128e2d5d3a.tar.gz
gentoo-ac6755b2fdfe094c5bc18d97b973f4128e2d5d3a.tar.bz2
gentoo-ac6755b2fdfe094c5bc18d97b973f4128e2d5d3a.zip
dev-python/testrepository: Drop unnecessary die
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/testrepository')
-rw-r--r--dev-python/testrepository/testrepository-0.0.17-r1.ebuild28
-rw-r--r--dev-python/testrepository/testrepository-0.0.17-r2.ebuild23
-rw-r--r--dev-python/testrepository/testrepository-0.0.18-r1.ebuild2
3 files changed, 30 insertions, 23 deletions
diff --git a/dev-python/testrepository/testrepository-0.0.17-r1.ebuild b/dev-python/testrepository/testrepository-0.0.17-r1.ebuild
index 54eebcdb8cfe..7f8d670c3816 100644
--- a/dev-python/testrepository/testrepository-0.0.17-r1.ebuild
+++ b/dev-python/testrepository/testrepository-0.0.17-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
+
# Although package supports alt. py impls, only works fully under py2.7
PYTHON_COMPAT=( python2_7 )
@@ -17,18 +18,21 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/subunit[${PYTHON_USEDEP}]
- >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}]
- dev-python/testresources[${PYTHON_USEDEP}]
- dev-python/testscenarios[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- )"
-#bzr is listed but presumably req'd for a live repo test run
-RDEPEND="dev-python/subunit[${PYTHON_USEDEP}]
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/subunit[${PYTHON_USEDEP}]
>=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}]"
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/testresources[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+#bzr is listed but presumably req'd for a live repo test run
+RDEPEND="
+ dev-python/subunit[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]"
python_test() {
"${PYTHON}" ./testr init || die
diff --git a/dev-python/testrepository/testrepository-0.0.17-r2.ebuild b/dev-python/testrepository/testrepository-0.0.17-r2.ebuild
index 78b8870e928c..d66490e91c63 100644
--- a/dev-python/testrepository/testrepository-0.0.17-r2.ebuild
+++ b/dev-python/testrepository/testrepository-0.0.17-r2.ebuild
@@ -3,6 +3,7 @@
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python{2_7,3_3} )
inherit distutils-r1
@@ -16,24 +17,26 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/testresources[${PYTHON_USEDEP}]
- dev-python/testscenarios[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- )"
#>=dev-python/subunit-0.0.10[${PYTHON_USEDEP}]
#>=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
#dev-python/fixtures[${PYTHON_USEDEP}]
#bzr is listed but presumably req'd for a live repo test run
-RDEPEND=">=dev-python/subunit-0.0.10[${PYTHON_USEDEP}]
- >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/subunit-0.0.10[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/testresources[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
# Required for test phase
DISTUTILS_IN_SOURCE_BUILD=1
python_test() {
"${PYTHON}" ./testr init || die
- "${PYTHON}" setup.py testr --coverage || die "tests failed under ${EPYTHON}"
+ esetup.py testr --coverage
}
diff --git a/dev-python/testrepository/testrepository-0.0.18-r1.ebuild b/dev-python/testrepository/testrepository-0.0.18-r1.ebuild
index f2ea60551810..a5d520941b04 100644
--- a/dev-python/testrepository/testrepository-0.0.18-r1.ebuild
+++ b/dev-python/testrepository/testrepository-0.0.18-r1.ebuild
@@ -38,5 +38,5 @@ python_test() {
# some errors appear to have crept in the suite undert py3 since addition.
# Python2.7 now passes all.
- esetup.py testr --coverage # || die "tests failed under ${EPYTHON}"
+ esetup.py testr --coverage
}