summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/testresources
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/testresources')
-rw-r--r--dev-python/testresources/Manifest1
-rw-r--r--dev-python/testresources/metadata.xml20
-rw-r--r--dev-python/testresources/testresources-0.2.7-r2.ebuild27
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/testresources/Manifest b/dev-python/testresources/Manifest
new file mode 100644
index 000000000000..00ce0840b274
--- /dev/null
+++ b/dev-python/testresources/Manifest
@@ -0,0 +1 @@
+DIST testresources-0.2.7.tar.gz 32050 SHA256 ad0a117383dd463827b199eaa92829b4d6a3147fbd97459820df53bae81d7231 SHA512 29518f7326272c56a5f2f3f1f7741959dde9265ba5ce7e0c7d7afabd91bd44a519d1cad82a11a41944ff12d65e541536476f87afcac9a7cbb4869743a38547b7 WHIRLPOOL c414223960fbd6a1c612d2c79c8b8956ab858aaaa76331ddefb1315dbdd6c6bc1d3a7641c098d7d558b332ee8f4262d8921240adb63f581a3127da6a617dc200
diff --git a/dev-python/testresources/metadata.xml b/dev-python/testresources/metadata.xml
new file mode 100644
index 000000000000..e8c27a4d1dc8
--- /dev/null
+++ b/dev-python/testresources/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Testresources extends unittest with a clean and simple api to provide test
+ optimisation where expensive common resources are needed for test cases
+ for example sample working trees for VCS systems, reference databases for
+ enterprise applications, or web servers ... let imagination run wild.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">testresources</remote-id>
+ <remote-id type="launchpad">testresources</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/testresources/testresources-0.2.7-r2.ebuild b/dev-python/testresources/testresources-0.2.7-r2.ebuild
new file mode 100644
index 000000000000..b4f611fc6a06
--- /dev/null
+++ b/dev-python/testresources/testresources-0.2.7-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Testresources, a pyunit extension for managing expensive test resources"
+HOMEPAGE="https://launchpad.net/testresources"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}