summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-24 08:15:21 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-24 12:12:08 +0200
commit6f7492b2a24659ec50f94d5667c3b001f81ce713 (patch)
tree3ab0f4a4e99d90acf511f15f67c61ac5c1fb2fd5 /dev-python/testresources
parentdev-python/testscenarios: Add pypy* support (diff)
downloadgentoo-6f7492b2a24659ec50f94d5667c3b001f81ce713.tar.gz
gentoo-6f7492b2a24659ec50f94d5667c3b001f81ce713.tar.bz2
gentoo-6f7492b2a24659ec50f94d5667c3b001f81ce713.zip
dev-python/testresources: Add pypy3 support
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/testresources')
-rw-r--r--dev-python/testresources/testresources-0.2.7-r2.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/testresources/testresources-0.2.7-r2.ebuild b/dev-python/testresources/testresources-0.2.7-r2.ebuild
index b4f611fc6a06..cb77788f9f89 100644
--- a/dev-python/testresources/testresources-0.2.7-r2.ebuild
+++ b/dev-python/testresources/testresources-0.2.7-r2.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
inherit distutils-r1
@@ -16,10 +17,13 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}] )"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )"
RDEPEND=""
python_test() {