summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-23 10:12:43 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-23 11:05:31 +0100
commita99f9be497019dda3200147994eca765a8846e61 (patch)
tree8367176ec8a56580cbae51c1006e943b1fe923a9 /dev-python/testtools/testtools-1.7.1.ebuild
parentdev-python/lockfile: Drop old (diff)
downloadgentoo-a99f9be497019dda3200147994eca765a8846e61.tar.gz
gentoo-a99f9be497019dda3200147994eca765a8846e61.tar.bz2
gentoo-a99f9be497019dda3200147994eca765a8846e61.zip
dev-python/testtools: Drop old
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/testtools/testtools-1.7.1.ebuild')
-rw-r--r--dev-python/testtools/testtools-1.7.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/testtools/testtools-1.7.1.ebuild b/dev-python/testtools/testtools-1.7.1.ebuild
deleted file mode 100644
index 8ffd592f86f4..000000000000
--- a/dev-python/testtools/testtools-1.7.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Extensions to the Python standard library unit testing framework"
-HOMEPAGE="https://github.com/testing-cabal/testtools"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~sparc"
-IUSE="doc"
-
-CDEPEND="
- dev-python/extras[${PYTHON_USEDEP}]
- dev-python/mimeparse[${PYTHON_USEDEP}]
- >=dev-python/unittest2-1.0.0[${PYTHON_USEDEP}]
- dev-python/traceback2[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-RDEPEND="${CDEPEND}"
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- "${PYTHON}" -m testtools.run testtools.tests.test_suite || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
-}