summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-17 11:56:45 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-17 12:03:36 +0100
commit92ac6a12c1b1cd26901473e4a6bb4a06ede00825 (patch)
treeebb08d34b0c8fc9504e80c2fdde10b91b471f3fc /dev-python/testtools
parentdev-python/setuptools_scm: Version Bump (diff)
downloadgentoo-92ac6a12c1b1cd26901473e4a6bb4a06ede00825.tar.gz
gentoo-92ac6a12c1b1cd26901473e4a6bb4a06ede00825.tar.bz2
gentoo-92ac6a12c1b1cd26901473e4a6bb4a06ede00825.zip
dev-python/testtools: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/testtools')
-rw-r--r--dev-python/testtools/Manifest1
-rw-r--r--dev-python/testtools/testtools-1.8.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/testtools/Manifest b/dev-python/testtools/Manifest
index 9ba454caefb0..0c5a4815b861 100644
--- a/dev-python/testtools/Manifest
+++ b/dev-python/testtools/Manifest
@@ -4,3 +4,4 @@ DIST testtools-1.3.0.tar.gz 204755 SHA256 3bf0be7c76587e8318936462438124ffb74372
DIST testtools-1.5.0.tar.gz 205197 SHA256 8d22a559f15b4540e069df0d69698d5bc70d9c42c8694c5e253595d70283511a SHA512 187a3f65eb3b00382853b8490d598f71990398f5867e985be00d13b87bb3ed155e9ecd3c16a268adf16ddf730b58a7d8849a8ba313668fc10af317e3eb3c825e WHIRLPOOL de91a36d9abc18680dba0f1c2b94133fe07d387093ee70a8f7bed2685faf55bbcbb46b5f9fcab0cdab73de382fabf800e78fa48889a733b9bceee06a61d3cbf9
DIST testtools-1.7.1.tar.gz 202573 SHA256 e9999eecf002a9fdc499ab82c13cc7b40226ed4b5fc4ed2a2c1cfb08fe23cfea SHA512 ca38d61abf2fa9589177f986f57f15abd3105ed26b834c136cb12592a0aaa1bbe62d5bc3914ec958daad323091e8d88fd3ccad68c5d970a67d84188baa53ba41 WHIRLPOOL b38f00016d82852a58350d1a456b861af9c6a3e1f97d40463b225c7b6349b765680b45af6e18f21e05c88d40ce3c02445b04072c48d0f433176a4d718f907f88
DIST testtools-1.8.0.tar.gz 207976 SHA256 8afd6400fb4e75adb0b29bd09695ecb2024cd7befab4677a58c147701afadd97 SHA512 b5f0201222d1e8c60fb7c2793bcd38e1c96c6f9fae99e9f3e784d17230c9abbf7325053d501c07e752bad2da36b49e2c79a25d0c20cb9a2f426057f839a77b3a WHIRLPOOL 71d4082197a9c179862fc3c63eadc37d6ff776f0a62e5fb08c296a5bf7109dc5110a2104a1ed15ca97c523aa0afb9e7124805ec6a6ae18f7605d7641abd9c54a
+DIST testtools-1.8.1.tar.gz 209327 SHA256 155ed29086e48156519e15f7801b702c15ba34d8700d80ba606101f448a3839f SHA512 0bd765bd3cc82a38c980d251427f9f32d44c377aa753d2d83c36fb8cfaeb8a10cfc86a38899b89ff454fe11742ab5e309439980e12a8bbae19b3d9df799803d9 WHIRLPOOL 06f654e447b6ae42cffbff454886dc1016746bf218c90e89c4b9361af2dc709acdfdcd0100c1624dffc1f72dec5c8037dd4357aa373a6413abf945c0d27868e1
diff --git a/dev-python/testtools/testtools-1.8.1.ebuild b/dev-python/testtools/testtools-1.8.1.ebuild
new file mode 100644
index 000000000000..c9824956468a
--- /dev/null
+++ b/dev-python/testtools/testtools-1.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Extensions to the Python standard library unit testing framework"
+HOMEPAGE="https://github.com/testing-cabal/testtools"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND="
+ dev-python/extras[${PYTHON_USEDEP}]
+ dev-python/mimeparse[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+ >=dev-python/unittest2-1.0.0[${PYTHON_USEDEP}]
+ dev-python/traceback2[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ "${PYTHON}" -m testtools.run testtools.tests.test_suite || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+}