summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-22 21:42:48 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-23 01:10:51 +0100
commit916566b6a0d15d9c5ded022cffc6d1bcb481d53c (patch)
tree0146bd583d4349c65c95a570f398b8c4851b3e31 /dev-python/theano-pymc
parentdev-python/backrefs: Bump to 5.0 (diff)
downloadgentoo-916566b6a0d15d9c5ded022cffc6d1bcb481d53c.tar.gz
gentoo-916566b6a0d15d9c5ded022cffc6d1bcb481d53c.tar.bz2
gentoo-916566b6a0d15d9c5ded022cffc6d1bcb481d53c.zip
dev-python/theano-pymc: Bump to 1.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/theano-pymc')
-rw-r--r--dev-python/theano-pymc/Manifest1
-rw-r--r--dev-python/theano-pymc/theano-pymc-1.1.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/theano-pymc/Manifest b/dev-python/theano-pymc/Manifest
index b85d83179619..4989b972adcb 100644
--- a/dev-python/theano-pymc/Manifest
+++ b/dev-python/theano-pymc/Manifest
@@ -1,4 +1,5 @@
DIST Theano-PyMC-rel-1.0.15.tar.gz 12978600 BLAKE2B 9038baa6d7c275a20a2e4f4f9e382f651deee958b2f044ad4360ea7d5a0408ab237af03857d5a598464c770ab1935d051d0f84657efd2915f5c80b393b972e04 SHA512 ad544b2749320ac2c3cd27e84e7700ce469e7d840491675378aabc3a75b03b26065c1022760fd1dae06f6cd694b4ec6de95e78280c478884ffdb224e4f0760ad
DIST Theano-PyMC-rel-1.1.0.tar.gz 12482951 BLAKE2B 3c3cf6bcd396ce01d68575d8272a9b110077ef8c2b4a6c8f0e795dafcf75f862e145d4e9d83289950e8d463098fe0ebbcee8f4d5f0867d9e6c673c77d6fe8b90 SHA512 667c0b3662ee41254d1776060d64d46b58980ac4ae4e7b271d29d7e09321089946e4aa864626b6e8ea1bd2eae330688b675d507e18dce2d92a4a8df5a0116bb6
+DIST Theano-PyMC-rel-1.1.1.tar.gz 12481810 BLAKE2B d0c40c9bcb25c65b38ed21092a1824c137f9942c8c2d1ab38b6ce9885a4e7be2bd096ed28fb7dc9397eae1477a47d9284b3e5536b563e033fd86af49d6479644 SHA512 d0462bdf6d7174b9c31a6e63b19ac7556f35787b962a7ec7a74cd53c12b8eb990730a5e155e55dc59f0bca20da26d4270ea50e8e32fe23118bb1c78912f69688
DIST theano-pymc-1.0.13.tar.gz 12975871 BLAKE2B 71528868885084d7c37f1f5cc5156aca5e764d09f0dc57aa46e21240ee2959aafb5882aef8977d9f215b051265d0d9bc3a7097ac0bb6d427cfc076ea6f591905 SHA512 da25e386965695a5630c54a671a7a573d0f0fae2eeeacf4f65130e4e4caf416373852ac14b1eb07ae39c194febe854d71fffe2adc24c348f64a4b73b43564229
DIST theano-pymc-1.0.14.tar.gz 12979426 BLAKE2B e6db87a348d6e7003f8b1ff4e0634335d53d734ea922951edeaab06ec54d51f1d7930a03f6dca14979930abb6212f873d606a9adada46d5b606854c5d8a6c6a5 SHA512 4ddfe5978f33cea96b20763cb01eecf1ec6c0c6b97ac892d647e28b607e61b11862739e5836356ab87e2002e992febe35ce9e1e72d37732074be2dbed64b50b9
diff --git a/dev-python/theano-pymc/theano-pymc-1.1.1.ebuild b/dev-python/theano-pymc/theano-pymc-1.1.1.ebuild
new file mode 100644
index 000000000000..221894445d0d
--- /dev/null
+++ b/dev-python/theano-pymc/theano-pymc-1.1.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1 optfeature
+
+MY_P=Theano-PyMC-rel-${PV}
+DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
+HOMEPAGE="https://github.com/pymc-devs/Theano-PyMC"
+SRC_URI="
+ https://github.com/pymc-devs/Theano-PyMC/archive/rel-${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc 'dev-python/sphinx_rtd_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e "s/tests.\*/tests\*/" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local exclude=(
+ # speed tests are unreliable
+ tests/scan/test_basic.py::test_speed
+ tests/scan/test_basic.py::test_speed_rnn
+ tests/scan/test_basic.py::test_speed_batchrnn
+ tests/link/test_vm.py::test_speed
+ tests/link/test_vm.py::test_speed_lazy
+ tests/tensor/test_gc.py::test_merge_opt_runtime
+ )
+
+ distutils_install_for_testing --via-root
+ pytest -vv ${exclude[@]/#/--deselect } \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
+ optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
+}