summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/thunarx-python
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/thunarx-python')
-rw-r--r--dev-python/thunarx-python/Manifest1
-rw-r--r--dev-python/thunarx-python/metadata.xml12
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.3.0-r1.ebuild44
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/thunarx-python/Manifest b/dev-python/thunarx-python/Manifest
new file mode 100644
index 000000000000..9832d0950476
--- /dev/null
+++ b/dev-python/thunarx-python/Manifest
@@ -0,0 +1 @@
+DIST thunarx-python-0.3.0.tar.bz2 303035 SHA256 5650e045565af82f3a5f67bbecb46182b502a37f94d08c23adac697dbb4ce258 SHA512 9be3e8b50cd668e0b63fbf54da5dec3685dde40528067b35bd1cfa87db7e037962baafce3059818a7de76101472a2b07ae209c590f2f143dbc71646e8addb28f WHIRLPOOL cfcf986b7ca9bc2fd50d4d5bbb80c6df7ac557e3ca15703eada5c71a302d4275cee7972d13cb3d746e064caeb9e90f366819045bc109d761bcc898ce5a70d577
diff --git a/dev-python/thunarx-python/metadata.xml b/dev-python/thunarx-python/metadata.xml
new file mode 100644
index 000000000000..db7cdefa7c62
--- /dev/null
+++ b/dev-python/thunarx-python/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/thunarx-python/thunarx-python-0.3.0-r1.ebuild b/dev-python/thunarx-python/thunarx-python-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..d9056e221cd0
--- /dev/null
+++ b/dev-python/thunarx-python/thunarx-python-0.3.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 xfconf
+
+DESCRIPTION="Python bindings for the Thunar file manager"
+HOMEPAGE="http://goodies.xfce.org/projects/bindings/thunarx-python"
+SRC_URI="mirror://xfce/src/bindings/${PN}/0.3/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND="${PYTHON_DEPS}
+ x11-libs/gtk+:2
+ dev-libs/glib:2
+ >=dev-python/pygobject-2.16:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ >=xfce-base/thunar-1.1.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+pkg_setup() {
+ XFCONF=(
+ --disable-dependency-tracking
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ xfconf_src_install \
+ docsdir=/usr/share/doc/${PF} \
+ examplesdir=/usr/share/doc/${PF}/examples
+}