summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-06 12:50:52 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-11 21:31:13 +0100
commitba648348c4cdbe3ed09c38c55c92ce7afe384855 (patch)
tree007693ca756a80578bd6abb3a6cdc8dc953422e6 /dev-python/tikzplotlib
parentdistutils-r1.eclass: Fix setuptools without setup.py (diff)
downloadgentoo-ba648348c4cdbe3ed09c38c55c92ce7afe384855.tar.gz
gentoo-ba648348c4cdbe3ed09c38c55c92ce7afe384855.tar.bz2
gentoo-ba648348c4cdbe3ed09c38c55c92ce7afe384855.zip
dev-python/tikzplotlib: Use distutils-r1 pyproject.toml support
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tikzplotlib')
-rw-r--r--dev-python/tikzplotlib/tikzplotlib-0.9.7.ebuild16
1 files changed, 1 insertions, 15 deletions
diff --git a/dev-python/tikzplotlib/tikzplotlib-0.9.7.ebuild b/dev-python/tikzplotlib/tikzplotlib-0.9.7.ebuild
index b1d6c8827e1d..eec9580243fc 100644
--- a/dev-python/tikzplotlib/tikzplotlib-0.9.7.ebuild
+++ b/dev-python/tikzplotlib/tikzplotlib-0.9.7.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1 virtualx
@@ -35,21 +36,6 @@ BDEPEND="
distutils_enable_tests pytest
distutils_enable_sphinx doc dev-python/mock
-python_prepare_all() {
- # setup.py was removed in commit f04323cfa575caf8a25a9236f55fe6baf1a33b20
- # for some reason, DISTUTULS_USE_SETUPTOOLS="pyproject.toml" is not working
- # it complains about file not found, setup.cfg does exist
-
- cat > setup.py <<EOF || die
-from setuptools import setup
-
-if __name__ == "__main__":
- setup()
-EOF
-
- distutils-r1_python_prepare_all
-}
-
python_test() {
local -x MPLBACKEND=Agg
virtx pytest -vv