summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-14 09:08:37 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-14 09:18:59 +0200
commit1d0fc656c85d7f0bfcceea27527e27ee66dcf900 (patch)
tree088c4a6e83712bd658697158d3641d2a9a7e6012 /dev-python/timeout-decorator
parentdev-python/reportlab: Bump to 3.5.67 (diff)
downloadgentoo-1d0fc656c85d7f0bfcceea27527e27ee66dcf900.tar.gz
gentoo-1d0fc656c85d7f0bfcceea27527e27ee66dcf900.tar.bz2
gentoo-1d0fc656c85d7f0bfcceea27527e27ee66dcf900.zip
dev-python/timeout-decorator: New dep of dev-python/requests-cache
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/timeout-decorator')
-rw-r--r--dev-python/timeout-decorator/Manifest1
-rw-r--r--dev-python/timeout-decorator/metadata.xml12
-rw-r--r--dev-python/timeout-decorator/timeout-decorator-0.5.0.ebuild25
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/timeout-decorator/Manifest b/dev-python/timeout-decorator/Manifest
new file mode 100644
index 000000000000..0433da47fd48
--- /dev/null
+++ b/dev-python/timeout-decorator/Manifest
@@ -0,0 +1 @@
+DIST timeout-decorator-9fbc3ef5b6f8f8cba2eb7ba795813d6ec543e265.tar.gz 6178 BLAKE2B dc89ba8c4fb861d3e69322b531a944ce6587800ea1f6d871fd5bd95e69ce4fca74c403cc430adefeda08675972a11e872e2296e14b7d7819c78a46fa08db5fa9 SHA512 2e691d40fcbe55a3d6be81f9744c2a06c436b61a17d701ad0e9df7003e7cf41b6e4876b48d4bd4a5b429ae2139e8f6ef8ae05092b599d80b3b5aa05716bb124e
diff --git a/dev-python/timeout-decorator/metadata.xml b/dev-python/timeout-decorator/metadata.xml
new file mode 100644
index 000000000000..cd4c8cbfb2ec
--- /dev/null
+++ b/dev-python/timeout-decorator/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">pnpnpn/timeout-decorator</remote-id>
+ <remote-id type="pypi">timeout-decorator</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/timeout-decorator/timeout-decorator-0.5.0.ebuild b/dev-python/timeout-decorator/timeout-decorator-0.5.0.ebuild
new file mode 100644
index 000000000000..7b4bfb970679
--- /dev/null
+++ b/dev-python/timeout-decorator/timeout-decorator-0.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+EGIT_COMMIT=9fbc3ef5b6f8f8cba2eb7ba795813d6ec543e265
+MY_P=${PN}-${EGIT_COMMIT}
+
+DESCRIPTION="Timeout decorator"
+HOMEPAGE="
+ https://pypi.org/project/timeout-decorator/
+ https://github.com/pnpnpn/timeout-decorator/"
+SRC_URI="
+ https://github.com/pnpnpn/timeout-decorator/archive/${EGIT_COMMIT}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest