summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-07-06 20:16:15 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-07-06 20:16:15 -0400
commitf41afad6822183065630f8accc9a27213ee6b543 (patch)
tree50b653db8fd4c986dba98f979ad05c6157b73f10 /dev-python/tinycss2/tinycss2-0.5.ebuild
parentdev-python/pytest-isort: Initial commit (diff)
downloadgentoo-f41afad6822183065630f8accc9a27213ee6b543.tar.gz
gentoo-f41afad6822183065630f8accc9a27213ee6b543.tar.bz2
gentoo-f41afad6822183065630f8accc9a27213ee6b543.zip
dev-python/tinycss2: Initial commit
Required by weasyprint. Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-python/tinycss2/tinycss2-0.5.ebuild')
-rw-r--r--dev-python/tinycss2/tinycss2-0.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/tinycss2/tinycss2-0.5.ebuild b/dev-python/tinycss2/tinycss2-0.5.ebuild
new file mode 100644
index 000000000000..aa53bc12e101
--- /dev/null
+++ b/dev-python/tinycss2/tinycss2-0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A complete yet simple CSS parser for Python"
+HOMEPAGE="https://github.com/SimonSapin/tinycss2/ http://pypi.python.org/pypi/tinycss2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="test"
+
+RDEPEND="dev-python/webencodings[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS=( CHANGES README.rst )
+
+python_test() {
+ py.test || die "testsuite failed under ${EPYTHON}"
+}