summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2019-07-18 17:27:09 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2019-07-18 17:31:34 -0400
commitf0df5bdaef0748e07ee24cec955b58fb4caa94dc (patch)
treef6844c77fc76fbcc306daffa77223bbbd7bb938f /dev-python/tinycss2/tinycss2-1.0.2.ebuild
parentdev-libs/libxml2: stable 2.9.9-r1 for hppa, bug #685254 (diff)
downloadgentoo-f0df5bdaef0748e07ee24cec955b58fb4caa94dc.tar.gz
gentoo-f0df5bdaef0748e07ee24cec955b58fb4caa94dc.tar.bz2
gentoo-f0df5bdaef0748e07ee24cec955b58fb4caa94dc.zip
dev-python/tinycss2: Fix dependencies, doc install
Added missing dependency declaration for tests. CHANGES dropped from distribution, so removes from DOCS. Closes: https://bugs.gentoo.org/690170 Closes: https://bugs.gentoo.org/690174 Package-Manager: Portage-2.3.66, Repoman-2.3.11 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-python/tinycss2/tinycss2-1.0.2.ebuild')
-rw-r--r--dev-python/tinycss2/tinycss2-1.0.2.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/tinycss2/tinycss2-1.0.2.ebuild b/dev-python/tinycss2/tinycss2-1.0.2.ebuild
index 6a89feef642b..40307a78ea0c 100644
--- a/dev-python/tinycss2/tinycss2-1.0.2.ebuild
+++ b/dev-python/tinycss2/tinycss2-1.0.2.ebuild
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python3_{5,6} )
inherit distutils-r1
DESCRIPTION="A complete yet simple CSS parser for Python"
-HOMEPAGE="https://github.com/SimonSapin/tinycss2/ https://pypi.python.org/pypi/tinycss2/"
+HOMEPAGE="https://github.com/Kozea/tinycss2/ https://pypi.python.org/pypi/tinycss2/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
@@ -16,16 +16,19 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-RDEPEND="dev-python/webencodings[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/webencodings-0.4[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
+ >=dev-python/setuptools-39.2.0[${PYTHON_USEDEP}]
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
dev-python/pytest-flake8[${PYTHON_USEDEP}]
dev-python/pytest-isort[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
)
"
-DOCS=( CHANGES README.rst )
+DOCS=( README.rst )
python_test() {
py.test || die "testsuite failed under ${EPYTHON}"