summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-12 21:39:00 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-12 21:40:23 +0200
commitba2add082eefd5719275c3533039dc072c120d18 (patch)
treec3ad53ef56e13a39e2ed3edf3923f5e7b2bd21db /dev-python/tldextract
parentdev-python/tldextract: add github upstream metadata (diff)
downloadgentoo-ba2add082eefd5719275c3533039dc072c120d18.tar.gz
gentoo-ba2add082eefd5719275c3533039dc072c120d18.tar.bz2
gentoo-ba2add082eefd5719275c3533039dc072c120d18.zip
dev-python/tldextract: add 3.1.0, py3.10, tests, fix deps
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/tldextract')
-rw-r--r--dev-python/tldextract/Manifest1
-rw-r--r--dev-python/tldextract/files/tldextract-3.1.0-skip-pylint.patch18
-rw-r--r--dev-python/tldextract/tldextract-3.1.0.ebuild31
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/tldextract/Manifest b/dev-python/tldextract/Manifest
index f68f73e708e0..ee6ef4a2807f 100644
--- a/dev-python/tldextract/Manifest
+++ b/dev-python/tldextract/Manifest
@@ -1 +1,2 @@
DIST tldextract-2.2.1.tar.gz 54538 BLAKE2B 0abfb1982d0b9e9cd767bc64db289da8bf2f58b599eaea7e703adf36934dae0d052170fa9a8205b8ac0b441d8f1ac75648ccc108515586b0bcacf2ecb43fef52 SHA512 db4f14e514c0e68f85f28226343d7ec91ceea2843ee01c9a2950f0972f365bf343640e07cfb118aff52bab975719be71d179fc6b3bd4da7eb62a47b62747cc0b
+DIST tldextract-3.1.0.tar.gz 101874 BLAKE2B 105f34699de2118126dc0f9d68f25999f99211aa8529c2640dd21d303cfb18cd5388819986881e235b8111a21b74d99c6424ad469a66a0ac45c25a0e7c31a21f SHA512 c6c67598b7dd2c8e85008c5061693182eb075e16390b001eb696fd12a0f5666d0a327667a0fd61e4f270003a8cfc97a8fbf7b53a246bab6f9e9ad95943dac9d8
diff --git a/dev-python/tldextract/files/tldextract-3.1.0-skip-pylint.patch b/dev-python/tldextract/files/tldextract-3.1.0-skip-pylint.patch
new file mode 100644
index 000000000000..c80541d79ce3
--- /dev/null
+++ b/dev-python/tldextract/files/tldextract-3.1.0-skip-pylint.patch
@@ -0,0 +1,18 @@
+From f189ebb3ecf60b9764852021988112df5c9e25c7 Mon Sep 17 00:00:00 2001
+From: Louis Sautier <sautier.louis@gmail.com>
+Date: Thu, 12 Aug 2021 13:34:52 +0200
+Subject: [PATCH] tests: do not run pylint by default
+
+There is already a separate tox environment to run pylint tests.
+---
+ pytest.ini | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pytest.ini b/pytest.ini
+index 6d94ff5..df3eb51 100644
+--- a/pytest.ini
++++ b/pytest.ini
+@@ -1,2 +1,2 @@
+ [pytest]
+-addopts = --doctest-modules --pylint
++addopts = --doctest-modules
diff --git a/dev-python/tldextract/tldextract-3.1.0.ebuild b/dev-python/tldextract/tldextract-3.1.0.ebuild
new file mode 100644
index 000000000000..8ec2fc7da164
--- /dev/null
+++ b/dev-python/tldextract/tldextract-3.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Accurately separate the TLD from the registered domain and subdomains of a URL."
+HOMEPAGE="https://pypi.org/project/tldextract/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-file[${PYTHON_USEDEP}]
+"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/john-kurkowski/tldextract/pull/230
+ "${FILESDIR}/${P}-skip-pylint.patch"
+)