summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-02 08:38:54 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-02 09:12:24 +0100
commit33c9f128b887b56ac90b59bfca1aacbec53f8722 (patch)
tree15ea4a15b821e7dbc73e3cbcbb3a517274497fd6 /dev-python/tomli-w
parentapp-admin/awscli: Bump to 1.22.18 (diff)
downloadgentoo-33c9f128b887b56ac90b59bfca1aacbec53f8722.tar.gz
gentoo-33c9f128b887b56ac90b59bfca1aacbec53f8722.tar.bz2
gentoo-33c9f128b887b56ac90b59bfca1aacbec53f8722.zip
dev-python/tomli-w: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomli-w')
-rw-r--r--dev-python/tomli-w/Manifest1
-rw-r--r--dev-python/tomli-w/tomli-w-1.0.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/tomli-w/Manifest b/dev-python/tomli-w/Manifest
index fe492e2f4aa0..3503f96d25b4 100644
--- a/dev-python/tomli-w/Manifest
+++ b/dev-python/tomli-w/Manifest
@@ -1,2 +1,3 @@
DIST tomli-w-0.3.0.gh.tar.gz 61366 BLAKE2B 1ca3d50237d41fb22e8d506d2d8af3c5d9f690161a44439d3a79038bda7a67a6af9ad62b077169b5c2bdaee2110a3be5e3eec652aa8866a20c5841662f18a7e1 SHA512 618b93f2d98eee4fafe502e25f8770dc58558b25d9ec548fa5d0a6bdd8914e487fb1d16b68d138e0f8a48a6e5713c23e4d1a6daf70c8eafa27630fee05dfe8df
DIST tomli-w-0.4.0.gh.tar.gz 63717 BLAKE2B 13f73718e84602e65243708481c546379120741bdef2c9b5dd53fc0a8f81bb098acfc18d8623d3b4ad9fe0ac37594c3c0fee94e009428cde2b46b6819f5598d1 SHA512 0a3940fd738aa62c9409cf33c515c33e232796374c10a7d0b0a7fcaf2d39e846cc1cf87700b5e8d5601e4bd02e76f5ee322c9d5fb37d4706670d34d8313fd19d
+DIST tomli-w-1.0.0.gh.tar.gz 63862 BLAKE2B f10dc80ce76edafd78fc66dd488a35bb0e1d8bf31d0cc0e3b970be19f5cda40d992fafd46d1361b55df4a787d48f38260ac2be77def7ac938f62144e4c810897 SHA512 406f81e4e8151e55e8367031b5880f51de41016711238a114c82962012de4b90d5e465c503a8979d565d07843fbc4804a53c29848e4f6e5f20f9ec5dc5ce536a
diff --git a/dev-python/tomli-w/tomli-w-1.0.0.ebuild b/dev-python/tomli-w/tomli-w-1.0.0.ebuild
new file mode 100644
index 000000000000..c7fe066b486f
--- /dev/null
+++ b/dev-python/tomli-w/tomli-w-1.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A lil' TOML writer"
+HOMEPAGE="
+ https://pypi.org/project/tomli-w/
+ https://github.com/hukkin/tomli-w/"
+SRC_URI="
+ https://github.com/hukkin/tomli-w/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ test? ( dev-python/tomli[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest