summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-04 21:17:44 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-04 21:35:00 +0200
commit363c9acaad279261010253c3fe3b58b871d95a96 (patch)
tree85b947fbb02bf6c1f2b4740d60b5a652fe3367c2 /dev-python/tomli
parentdev-util/pkgconf: add base-system to maintainers (diff)
downloadgentoo-363c9acaad279261010253c3fe3b58b871d95a96.tar.gz
gentoo-363c9acaad279261010253c3fe3b58b871d95a96.tar.bz2
gentoo-363c9acaad279261010253c3fe3b58b871d95a96.zip
dev-python/tomli: Fix circular dep with pyproject2setuppy
Write a trivial setup.py to avoid the circular dependency between dev-python/tomli and dev-python/pyproject2setuppy. Closes: https://bugs.gentoo.org/806396 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomli')
-rw-r--r--dev-python/tomli/tomli-1.0.4.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/tomli/tomli-1.0.4.ebuild b/dev-python/tomli/tomli-1.0.4.ebuild
index b35f22cf0cf9..7ad7d69a48f2 100644
--- a/dev-python/tomli/tomli-1.0.4.ebuild
+++ b/dev-python/tomli/tomli-1.0.4.ebuild
@@ -3,7 +3,6 @@
EAPI=8
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
@@ -23,3 +22,13 @@ BDEPEND="
test? ( dev-python/python-dateutil[${PYTHON_USEDEP}] )"
distutils_enable_tests pytest
+
+src_prepare() {
+ # we don't use pyproject.toml to avoid circular deps
+ cat > setup.py <<-EOF || die
+ from setuptools import setup
+ setup(name="tomli", version="${PV}", packages=["tomli"], package_data={"": ["*"]})
+ EOF
+
+ distutils-r1_src_prepare
+}