summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-05-21 17:56:40 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-05-21 17:57:01 -0400
commitd6c55c1208cb1912d631d59e64f2f048cd5303eb (patch)
tree0212e6cb8c3b0c5ddaf71d36c95aebfe6c96e933 /dev-python/tox/tox-3.11.1.ebuild
parentmedia-libs/Field3D: EAPI-7 bump, USE mpi, add proper src_configure() (diff)
downloadgentoo-d6c55c1208cb1912d631d59e64f2f048cd5303eb.tar.gz
gentoo-d6c55c1208cb1912d631d59e64f2f048cd5303eb.tar.bz2
gentoo-d6c55c1208cb1912d631d59e64f2f048cd5303eb.zip
dev-python/tox: bump to 3.11.1
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python/tox/tox-3.11.1.ebuild')
-rw-r--r--dev-python/tox/tox-3.11.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/tox/tox-3.11.1.ebuild b/dev-python/tox/tox-3.11.1.ebuild
new file mode 100644
index 000000000000..586d4e574d5c
--- /dev/null
+++ b/dev-python/tox/tox-3.11.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.org/project/tox/"
+SRC_URI="https://github.com/tox-dev/tox/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+# doc disabled because of missing deps in tree
+IUSE="test"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ <dev-python/pluggy-1.0[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
+ <dev-python/flaky-4
+ >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+ <dev-python/pytest-mock-2.0[${PYTHON_USEDEP}]
+ )"
+
+# for some reason, --deselect doesn't work in tox's tests
+PATCHES=(
+ "${FILESDIR}/${PN}-3.10.0-skip-broken-tests.patch"
+ "${FILESDIR}/${PN}-3.9.0-strip-setuptools_scm.patch"
+)
+
+python_test() {
+ distutils_install_for_testing
+ pytest -v --no-network || die "Testsuite failed under ${EPYTHON}"
+}