summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-19 22:37:38 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-19 22:37:38 +0100
commit4fdc63113d493d098ff9fb0b91f6ed9299b3c41f (patch)
treeaac5e4f37b4755889b02b7593456140469d6f998 /dev-python/tox
parentdev-python/sphinx: Remove old (diff)
downloadgentoo-4fdc63113d493d098ff9fb0b91f6ed9299b3c41f.tar.gz
gentoo-4fdc63113d493d098ff9fb0b91f6ed9299b3c41f.tar.bz2
gentoo-4fdc63113d493d098ff9fb0b91f6ed9299b3c41f.zip
dev-python/tox: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-3.21.4.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index b7d9e290963a..567c199053c4 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,3 +1,2 @@
-DIST tox-3.21.4.tar.gz 301889 BLAKE2B 166864fe9f44fe01d3b36481ba63738d4290bb609c6ea7e3dde3494ab7ba009c31b12c0801f5be9dfca6f56059f94438cfa31bc45dec862afda5bea763e37be0 SHA512 de12e8ba0f3287be2fced61573b3e2dfdf8513a947724982d0e17ff215489994985067692c94c499047a8b0e2dd843e214e958367199bfa6e0adcde4e09b8106
DIST tox-3.22.0.tar.gz 302088 BLAKE2B f9ef6feb9fa438b668f6a1b6f8846845f1cfcb0826ffacc04c52dfe0a968a7df2542acc8f4a1e69c634a7866672dbb78ab8f04ba7d6e94f88b40f6c3dd042571 SHA512 d96c31c9faa4d76a6181ce332e70ec9ccfb0a6b96feff45793393f3fd2d08668fc6f14da9164947c4b93f371fab3b9d23c87b38dac89ece18e87494ac3a7caac
DIST tox-3.23.0.tar.gz 303091 BLAKE2B 609e74ea354ca5daf45c848000961782fcef59da07f815292355d72f3e5dd078e3b5909a65521a4a1032fa2bb9481fdab0e620f4882b33aa377de9764296761c SHA512 fb96cbbdbd36399036d348716f1181285184985922e0dc61b610b36e53ea79e2d8a77190aad893650bcba86ef4c57ff0f2de2813becb2a12fe0d1aa36bb27ad3
diff --git a/dev-python/tox/tox-3.21.4.ebuild b/dev-python/tox/tox-3.21.4.ebuild
deleted file mode 100644
index 78e1824c9517..000000000000
--- a/dev-python/tox/tox-3.21.4.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="virtualenv-based automation of test activities"
-HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.org/project/tox/"
-SRC_URI="https://github.com/tox-dev/tox/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 sparc x86"
-# doc disabled because of missing deps in tree
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/filelock[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-1.1[${PYTHON_USEDEP}]
- ' python3_{5,6,7} pypy3)
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/py[${PYTHON_USEDEP}]
- >=dev-python/six-1.14[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]"
-# TODO: figure out how to make tests work without the package being
-# installed first.
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
- >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
- >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )"
-
-src_configure() {
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}
-
-python_test() {
- local deselect=(
- # broken without Internet
- tests/unit/session/test_provision.py::test_provision_non_canonical_dep
- tests/integration/test_provision_int.py::test_provision_interrupt_child
-
- # expects python2 to exist
- tests/unit/interpreters/test_interpreters.py::test_tox_get_python_executable
-
- # broken without tox installed first
- # TODO: figure out how to make importlib_metadata work
- tests/unit/test_z_cmdline.py::test_tox_console_script
- tests/unit/test_z_cmdline.py::test_tox_quickstart_script
- )
-
- [[ ${EPYTHON} != pypy3 ]] && deselect+=(
- # TODO?
- tests/unit/interpreters/test_interpreters.py::test_find_alias_on_path
-
- # broken without tox installed first
- # TODO: why it can't import itself?
- tests/integration/test_parallel_interrupt.py::test_parallel_interrupt
- )
-
- distutils_install_for_testing --via-root
- pytest -vv --no-network ${deselect[@]/#/--deselect } || die "Testsuite failed under ${EPYTHON}"
-}