summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-29 09:42:42 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-29 10:00:17 +0100
commita5b15c5cbb6188aefa2e8301cc8bd326f6dfd8b8 (patch)
tree13365b5770567a5d2ab132110139965b6d94cb8e /dev-python/tox
parentdev-python/xdoctest: Bump to 0.15.3 (diff)
downloadgentoo-a5b15c5cbb6188aefa2e8301cc8bd326f6dfd8b8.tar.gz
gentoo-a5b15c5cbb6188aefa2e8301cc8bd326f6dfd8b8.tar.bz2
gentoo-a5b15c5cbb6188aefa2e8301cc8bd326f6dfd8b8.zip
dev-python/tox: Bump to 3.21.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-3.21.3.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 7cb7de763aac..b5afa37cd9f0 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -2,3 +2,4 @@ DIST tox-3.20.1.tar.gz 297516 BLAKE2B 2a13059bce229f30670e247b17ffd03d4b0d907b2f
DIST tox-3.21.0.tar.gz 300962 BLAKE2B 360aedb86ef1f918e73f726af238d8fdb20c3217b45ef068ec833b14e17af018c1115a2df43b441b9a4af802c4aee2fcaa9bac8f519028dd05b112902c47b2ce SHA512 50041660839cc081d491f867db74c6e95c93b81b2264785b3ccf7b80fbf3a1250028755ddc4243a285ebd005e12f897001d6ea7efd45d0278ce3cb14f7021572
DIST tox-3.21.1.tar.gz 301387 BLAKE2B 3b15a17cfa8f2df1c8c3558cacde81d818cbc72b3dd0c4e4868d2fedace61c85ed484ad08e8abec10c0bef4062e623c75e4bf1122b4d15151b741057ea90fba3 SHA512 c3feaf1832db2b16df444d52ea774602c9a68eabd379c86483d33716f414df901b5e95ea9d63dd7c2f4338227cb5d9ee521a56f2dbb0d9c7d21221f49d1fc335
DIST tox-3.21.2.tar.gz 301587 BLAKE2B 81d19e45a1d53000a2e9f956ed7b934f0f1926b4270ddced997ddc8b77a1f05388e0907d379dbabaafd5e6fdcd7031d5e87f206fff385759318a89a5f3eebf58 SHA512 beb551f49af1f8661931f241cf73fa77a37a8061ade7d41b415a2fcecd4d5dd1ba7d3e3add248d3bc14627468fa896f3f4f532305bbc36d112d226b1961fd191
+DIST tox-3.21.3.tar.gz 301828 BLAKE2B d777a858c07d94b9239ecf8286bebc5b4efe1a79cd15b37dd2a717df06cb189d4ef3126da0523719289f8fb410965c4f9c06b02c56dfa5af6ad4fb6a60c6514f SHA512 1975efcab6af938058642a85675907dadc17bd14f881c074087b221cd22d42bd1fcd577bcbef134a499c9a5b2ee583af2b557657fbfb7db30261ff9d394cf82b
diff --git a/dev-python/tox/tox-3.21.3.ebuild b/dev-python/tox/tox-3.21.3.ebuild
new file mode 100644
index 000000000000..c21ec8453e95
--- /dev/null
+++ b/dev-python/tox/tox-3.21.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.org/project/tox/"
+SRC_URI="https://github.com/tox-dev/tox/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+# doc disabled because of missing deps in tree
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-1.1[${PYTHON_USEDEP}]
+ ' python3_{5,6,7} pypy3)
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]"
+# TODO: figure out how to make tests work without the package being
+# installed first.
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local deselect=(
+ # broken without Internet
+ tests/unit/session/test_provision.py::test_provision_non_canonical_dep
+ tests/integration/test_provision_int.py::test_provision_interrupt_child
+
+ # expects python2 to exist
+ tests/unit/interpreters/test_interpreters.py::test_tox_get_python_executable
+
+ # broken without tox installed first
+ # TODO: figure out how to make importlib_metadata work
+ tests/unit/test_z_cmdline.py::test_tox_console_script
+ tests/unit/test_z_cmdline.py::test_tox_quickstart_script
+ )
+
+ [[ ${EPYTHON} != pypy3 ]] && deselect+=(
+ # TODO?
+ tests/unit/interpreters/test_interpreters.py::test_find_alias_on_path
+
+ # broken without tox installed first
+ # TODO: why it can't import itself?
+ tests/integration/test_parallel_interrupt.py::test_parallel_interrupt
+ )
+
+ distutils_install_for_testing --via-root
+ pytest -vv --no-network ${deselect[@]/#/--deselect } || die "Testsuite failed under ${EPYTHON}"
+}