summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-07 09:12:37 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-07 09:12:37 +0200
commitf2fabafce1f958cb3621db65631dea448ade69f3 (patch)
treed45be76b729d5e47accdf889b0f560db2a00143d /dev-python/tox
parentdev-python/sortedcontainers: Bump to 2.2.1 (diff)
downloadgentoo-f2fabafce1f958cb3621db65631dea448ade69f3.tar.gz
gentoo-f2fabafce1f958cb3621db65631dea448ade69f3.tar.bz2
gentoo-f2fabafce1f958cb3621db65631dea448ade69f3.zip
dev-python/tox: Bump to 3.15.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-3.15.2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 2512f4aa3491..06767d919a64 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -4,4 +4,5 @@ DIST tox-3.14.4.tar.gz 289600 BLAKE2B 413782a524b70b4e301f5a4bda9c763dc7e670d7fe
DIST tox-3.14.5.tar.gz 290075 BLAKE2B 7e412e85981fe11cba4dc6a4ab3df824678b11fe59bd7d909361029f30e407ffe62a24967e5a447cc643500dfb61326d47fb276bb669311780ac49aa2075fe09 SHA512 cbd0e4c53bb82a302016f380a246e9a9630b8f0c6631195af2dfa12c090cc76c3d9da8362e11c42e74bacbb3f9be504eb67e07de1d2cbac7b5f05341ea2970c4
DIST tox-3.15.0.tar.gz 291890 BLAKE2B 9c42c587332eafcfd02d2d8a42588af6253baf9f62e82eb8a8bf10da291b4868b1fe319e38a583bc67bb26ab868b8a123feccd5bd008ce618ceb46d3121c68d2 SHA512 cb21574301d953b361eb5e1d89eefe22e68ae5871036f03d5753ee97c888cadde548d62a50622dd65b3c488143bbbdf8d309bafa3b6a4807871c9e78b6fcdb9c
DIST tox-3.15.1.tar.gz 292044 BLAKE2B eb3062fb1a2494a6b23e1c6f2c6af56be5879664ae26918e60839d2f8cff98dc6b684a27469eac81c363a3cd3e90abdafe0ab4dc601840023e5263a42301f384 SHA512 334e2129d5418d4733a25419b81cc57e794a11954c21774231e32c93e977f1a7fb71c739adabccb5cdde9428ab69772e8623a0c0a1172855957f7cbcd4a917b1
+DIST tox-3.15.2.tar.gz 293523 BLAKE2B a1a1c84a987d2b2e5194321405775ee3828b8e2c8dcd38c7e780a9d508b789a42f1880cffcecd68c50dfdc37008a4e9a117660fa2c732864c82af6c2eaf5a99e SHA512 9448554452c79039289d2d2c05c974f451647329701372c3e4b154a0161fa768245c0068cd5e3f1221b4b51a07be806f7c66ab9d4ef83a3e8e5964e18b9cde85
DIST tox-3.2.1.tar.gz 268827 BLAKE2B 764835d04fb0c17f32eb8e2041b83f90d6a729b781a5b5b95e9ecb1162f1c29ed595d4a6369524b390a31853b8003485b27a3a12d63e84f49e92675f1a9bee13 SHA512 79f5a1c8f6e818fbb8444754e3767d880fc1fdfe63b46c518d37440fe2b2f3ce572865aff83d9492c24486fded49893cc31bd9b11254bac4db507260304bc76f
diff --git a/dev-python/tox/tox-3.15.2.ebuild b/dev-python/tox/tox-3.15.2.ebuild
new file mode 100644
index 000000000000..0365e6a79004
--- /dev/null
+++ b/dev-python/tox/tox-3.15.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.org/project/tox/"
+SRC_URI="https://github.com/tox-dev/tox/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# doc disabled because of missing deps in tree
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-1.1[${PYTHON_USEDEP}]
+ ' python3_{5,6,7} pypy3)
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]"
+# TODO: figure out how to make tests work without the package being
+# installed first.
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ =dev-python/tox-${PV}-${PR}[${PYTHON_USEDEP}]
+ )"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # broken without internet
+ sed -i -e 's:test_provision_non_canonical_dep:_&:' \
+ tests/unit/session/test_provision.py || die
+ sed -i -e 's:test_provision_interrupt_child:_&:' \
+ tests/integration/test_provision_int.py || die
+ # broken with our mock version (?)
+ sed -i -e 's:test_create_KeyboardInterrupt:_&:' \
+ tests/unit/test_venv.py || die
+ # broken with Gentoo Python layout
+ sed -i -e 's:test_tox_get_python_executable:_&:' \
+ -e 's:test_find_alias_on_path:_&:' \
+ tests/unit/interpreters/test_interpreters.py || die
+
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv --no-network || die "Testsuite failed under ${EPYTHON}"
+}