summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-02 17:45:15 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-02 17:51:13 +0100
commit02aee21492f38603c579df8e00e1c88eb60fa806 (patch)
tree856aed4e6074f316cbb32630a7c3cc1a4beba473 /dev-python/tqdm
parentdev-python/hypothesis: Bump to 5.43.9 (diff)
downloadgentoo-02aee21492f38603c579df8e00e1c88eb60fa806.tar.gz
gentoo-02aee21492f38603c579df8e00e1c88eb60fa806.tar.bz2
gentoo-02aee21492f38603c579df8e00e1c88eb60fa806.zip
dev-python/tqdm: Bump to 4.55.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.55.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index ad178c210d0d..72190e511563 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,2 +1,3 @@
DIST tqdm-4.54.0.tar.gz 178664 BLAKE2B 68d0f054b2c95079e13ad9df3e9467f48925311151e5eed94795d3fab232301da99c2704daafd80f748037a467d25416913f0921d6b7c44d725c5ed6861fe347 SHA512 dbb2a61df848ebd84ab805134b7e7297e1cf7626abaa830a08159ce7b1852eba40a6a7f2cc7c8445294a184bbfbd69bf08430371f3e2d71f6a622a271ba49e95
DIST tqdm-4.55.0.tar.gz 161594 BLAKE2B 890bbb47db356678be2c3edd893d70b085f5bc8fefbf87f12ba8c69fe14ac523a1eed6e335fb84f2ff43b2b0fea901411f8a72b24212cb2ad5ef4955ec8f2df5 SHA512 84062f7d2a109e4067e0868990b6e53578c7c2ec2b81a0cbdc980c91d2d82a8bda37e0c9688777fcf14cc80b7ddf7b28b7a5acfe37608e37903fe45908103913
+DIST tqdm-4.55.1.tar.gz 161638 BLAKE2B 0149269f1ea854589647deb4ddd7415748924942ecc03d5fd6231470e5df959c1b8034d4d8416d83aa0a43ad1fafed15789f7ebaac12e5d525a7fe0bee88752a SHA512 82a6d3d8e10d4c46e40e03e557febe9f7cac3cc01c01c9e29b20cf8f2adcc7370829fe5d4497ff0edb506bf38b9ec14de86377d1bbd9b8b9e57687d951ae683f
diff --git a/dev-python/tqdm/tqdm-4.55.1.ebuild b/dev-python/tqdm/tqdm-4.55.1.ebuild
new file mode 100644
index 000000000000..81b4fb498481
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.55.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Skip unpredictable performance tests
+ pytest -vv --ignore 'tests/tests_perf.py' ||
+ die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}