summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-24 08:32:52 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-24 08:59:09 +0200
commit0f3381f31a847ff588debeffed34426d85bae2c8 (patch)
treeef7c32c901483fec056121ce2c401423e7e92076 /dev-python/tqdm
parentdev-python/emcee: Bump to 3.1.1 (diff)
downloadgentoo-0f3381f31a847ff588debeffed34426d85bae2c8.tar.gz
gentoo-0f3381f31a847ff588debeffed34426d85bae2c8.tar.bz2
gentoo-0f3381f31a847ff588debeffed34426d85bae2c8.zip
dev-python/tqdm: Bump to 4.62.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.62.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index 53cda200a570..24aed6278a84 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,3 +1,4 @@
DIST tqdm-4.61.2.tar.gz 169665 BLAKE2B f5dff67eb549cab0dd667815c25f6e885a2e0cefc2ad68e97fdc09599eb41b13589f7a88d5a445813973454a5e5f835b3139651ec2e09b717db0fd6dc705890e SHA512 bc33e8fe00244f90f61ab51d0c7c0b98d5580efebd9758284d9dbe2a699eabeb0d92871eedc2f95f377e29dd0f7ea4b5247b96cb4cc1687dcfea3a9ed1152ab7
DIST tqdm-4.62.0.tar.gz 169668 BLAKE2B 64a3df2f00a4fcba6bb67ae15e04f392a73b54cf7284f3c013ad31d00317e9d84ac2e1feed302137aeb7ea9e3c9d1d730623cbd96e8c76c46df6382435146efa SHA512 dd60d5522b68086410ec5f02574477dcc33a887ef509cc1d1735921dd906f951180d6115680517b3abbd2cf6c4ee1c60b9c950654ea9b7642d52d28052326088
DIST tqdm-4.62.1.tar.gz 169567 BLAKE2B 99e14631abe19d20d0fd67e1f885c307544103928f22e8913952b35adc2e596d4efa54fa4fedf4efdb1f8b83efdcee5de25052d6aba1974a668ba44f80de37dc SHA512 485d5a88588d026b3311419839abd57f8092295a2e68341708aa2c4ff35a97e30e9eb0db0db4ef9b0fc19c4d7b575ec6f30b213b97cb7498a9267d7c6e0a57ce
+DIST tqdm-4.62.2.tar.gz 169564 BLAKE2B fd3484db22eda5db7431fc337e23cfcf44882efc56c8b10208d799c156fefb5aa70c69c7063315d86d3ff881b97b62ac0b5c8be73ad3546ad0728f3f544cadfa SHA512 a59a041fa239e215e541f07c66292c27bfe067f3f2eac2916662b4ef1faa630346dec9558a7f66a3456b3d2ddcd164f9381cb89e5ac8350d0295367bfc248a8c
diff --git a/dev-python/tqdm/tqdm-4.62.2.ebuild b/dev-python/tqdm/tqdm-4.62.2.ebuild
new file mode 100644
index 000000000000..be993f734871
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.62.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Skip unpredictable performance tests
+ epytest --ignore 'tests/tests_perf.py'
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}