summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-25 06:40:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-25 06:57:02 +0200
commit4c6dc19b6bf0acf31076e7905e5e006ea58bb088 (patch)
treee3201c2057b1e184099e0adf7240511c7bcfadb5 /dev-python/tqdm
parentdev-python/alembic: Bump to 1.6.4 (diff)
downloadgentoo-4c6dc19b6bf0acf31076e7905e5e006ea58bb088.tar.gz
gentoo-4c6dc19b6bf0acf31076e7905e5e006ea58bb088.tar.bz2
gentoo-4c6dc19b6bf0acf31076e7905e5e006ea58bb088.zip
dev-python/tqdm: Bump to 4.61.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.61.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index 1a6e028754ad..d710ebbec9f3 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1 +1,2 @@
DIST tqdm-4.60.0.tar.gz 174201 BLAKE2B 78f4e2c2189621b5d276b8a9c75bae1566b05888cce81d8281de358ad2817e9751395bcf529c07620cd1ec4431c78ed7c1400dc96e9c3a99ac92daf2551b2da5 SHA512 e76dda97323353725c8e30b254bacfa328b4708d37ba2d21dadd30fd26e76605d8f077f02f2047030c6ab9761710a0e86640153fee0e3a3f972db12266fcfde2
+DIST tqdm-4.61.0.tar.gz 169471 BLAKE2B 6710b057bc5cab7afc72681c469618b442d47a0aec4300f52a360af41fff082a96d3f67cb650978c924df210a1c56e2856f181d55cdcc5692713d53581932144 SHA512 7c13c98572ac2800b695cf38d6de84b348c20967187dfcd3a358fc3a9999bfda509d3b4fbb77272840e1568ed975fc038cfb4034288c72560e09a58fbdc636f1
diff --git a/dev-python/tqdm/tqdm-4.61.0.ebuild b/dev-python/tqdm/tqdm-4.61.0.ebuild
new file mode 100644
index 000000000000..4cec8fab24b5
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.61.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Skip unpredictable performance tests
+ epytest --ignore 'tests/tests_perf.py'
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}