summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-12 22:12:10 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-12 23:01:58 +0200
commitaaf3e47f5167279484e0d1e7501c399665dd4b24 (patch)
treefcaf3f169aeed7e405208e79fcc77f211c765d53 /dev-python/tqdm
parentmedia-video/pipewire: Use EPREFIX for udev rules dir (diff)
downloadgentoo-aaf3e47f5167279484e0d1e7501c399665dd4b24.tar.gz
gentoo-aaf3e47f5167279484e0d1e7501c399665dd4b24.tar.bz2
gentoo-aaf3e47f5167279484e0d1e7501c399665dd4b24.zip
dev-python/tqdm: Bump to 4.61.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.61.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index d710ebbec9f3..49ea7abe16cd 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,2 +1,3 @@
DIST tqdm-4.60.0.tar.gz 174201 BLAKE2B 78f4e2c2189621b5d276b8a9c75bae1566b05888cce81d8281de358ad2817e9751395bcf529c07620cd1ec4431c78ed7c1400dc96e9c3a99ac92daf2551b2da5 SHA512 e76dda97323353725c8e30b254bacfa328b4708d37ba2d21dadd30fd26e76605d8f077f02f2047030c6ab9761710a0e86640153fee0e3a3f972db12266fcfde2
DIST tqdm-4.61.0.tar.gz 169471 BLAKE2B 6710b057bc5cab7afc72681c469618b442d47a0aec4300f52a360af41fff082a96d3f67cb650978c924df210a1c56e2856f181d55cdcc5692713d53581932144 SHA512 7c13c98572ac2800b695cf38d6de84b348c20967187dfcd3a358fc3a9999bfda509d3b4fbb77272840e1568ed975fc038cfb4034288c72560e09a58fbdc636f1
+DIST tqdm-4.61.1.tar.gz 169637 BLAKE2B 8b89f320e13119b24a9e121747bce0b5c6625c31feb8c427a97e71da52797d9de764ce5e5c41c07d5954a1e5e4e21913335a4691837bc243db473821b2dad1ac SHA512 6092a30389380a511abc8bee7e6144556d6dc1a993ba4a2685707afa2838a12f472aa216ac5e55d144da74f9be1d398d4c6f5352986a200557e4aba67831a505
diff --git a/dev-python/tqdm/tqdm-4.61.1.ebuild b/dev-python/tqdm/tqdm-4.61.1.ebuild
new file mode 100644
index 000000000000..efd3b71ffe21
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.61.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{8..9} )
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Skip unpredictable performance tests
+ epytest --ignore 'tests/tests_perf.py'
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}