summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/tracing
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/tracing')
-rw-r--r--dev-python/tracing/Manifest2
-rw-r--r--dev-python/tracing/metadata.xml8
-rw-r--r--dev-python/tracing/tracing-0.7-r1.ebuild35
-rw-r--r--dev-python/tracing/tracing-0.8.ebuild35
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/tracing/Manifest b/dev-python/tracing/Manifest
new file mode 100644
index 000000000000..1c4116932d6e
--- /dev/null
+++ b/dev-python/tracing/Manifest
@@ -0,0 +1,2 @@
+DIST python-tracing_0.7.orig.tar.gz 18670 SHA256 9954a1b0cc6b957d15975b048f929bbdd46766d397a6fa51bf8f6498b9459276 SHA512 4d6f2fb6cef9dfa90bcd786d5d32c4974a3e2a60cb616a41931e88e474fe016e72863e4831c88363242cb4daed9e061a5380bf33903e3385ee0eeadd4ec24f93 WHIRLPOOL 221d6812efe8a3a9c6359dad0cd2ec0a4cd79871b9f3dd23b55c5215a19634f796a0f391f58c4e0b0d4c76368cebf7410503bf10c376897bc692ad1008445c6f
+DIST python-tracing_0.8.orig.tar.gz 18796 SHA256 808a064cc5fd1972fb07a7d72b4069cbff284ac7077bcd90eb2ce79d8b5c9ed0 SHA512 9a5262ce63dbcafff83a75586e90be280ff41f902d9f71f4274dac944db4196c6a5777e290ca5e49aa010fb3129d5352d8c10a554918375557525b9a56ac9096 WHIRLPOOL 0dbe1760553177669ce9f43f49ede989f8f51e68efa8d024dc6a862d0f8f1593058d6231b41b2ead1a085a8d771c6528f99d7b77f35145484f911f5fd62d36db
diff --git a/dev-python/tracing/metadata.xml b/dev-python/tracing/metadata.xml
new file mode 100644
index 000000000000..ea7bd021a21e
--- /dev/null
+++ b/dev-python/tracing/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/tracing/tracing-0.7-r1.ebuild b/dev-python/tracing/tracing-0.7-r1.ebuild
new file mode 100644
index 000000000000..cf8eab9aaa12
--- /dev/null
+++ b/dev-python/tracing/tracing-0.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+MY_P="python-${P}"
+
+inherit distutils-r1
+
+DESCRIPTION="Debug log/trace messages"
+HOMEPAGE="http://liw.fi/tracing/"
+SRC_URI="http://code.liw.fi/debian/pool/main/p/python-${PN}/python-${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ dodoc README
+ use doc && dohtml -r doc/_build/html/
+ if use examples; then
+ docompress -x usr/share/doc/${PF}/examples/
+ insinto usr/share/doc/${PF}/examples/
+ doins example.py
+ fi
+}
diff --git a/dev-python/tracing/tracing-0.8.ebuild b/dev-python/tracing/tracing-0.8.ebuild
new file mode 100644
index 000000000000..af7c703a4f5a
--- /dev/null
+++ b/dev-python/tracing/tracing-0.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+MY_P="python-${P}"
+
+inherit distutils-r1
+
+DESCRIPTION="Debug log/trace messages"
+HOMEPAGE="http://liw.fi/tracing/"
+SRC_URI="http://code.liw.fi/debian/pool/main/p/python-${PN}/python-${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ dodoc README
+ use doc && dohtml -r doc/_build/html/
+ if use examples; then
+ docompress -x usr/share/doc/${PF}/examples/
+ insinto usr/share/doc/${PF}/examples/
+ doins example.py
+ fi
+}