summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 11:05:45 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 11:47:58 +0200
commit3d0d3634019486bb0c22f4cadd32eeadb8fa1834 (patch)
treed6adb1e84f86532fd71466d3e66a5067c09861da /dev-python/traits
parentdev-python/pyface: Clean old versions up (diff)
downloadgentoo-3d0d3634019486bb0c22f4cadd32eeadb8fa1834.tar.gz
gentoo-3d0d3634019486bb0c22f4cadd32eeadb8fa1834.tar.bz2
gentoo-3d0d3634019486bb0c22f4cadd32eeadb8fa1834.zip
dev-python/traits: Clean old versions up
Diffstat (limited to 'dev-python/traits')
-rw-r--r--dev-python/traits/traits-4.5.0-r1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/traits/traits-4.5.0-r1.ebuild b/dev-python/traits/traits-4.5.0-r1.ebuild
deleted file mode 100644
index cf82be9f5499..000000000000
--- a/dev-python/traits/traits-4.5.0-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
-HOMEPAGE="http://code.enthought.com/projects/traits/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-python_prepare() {
- if python_is_python3; then
- einfo "Converting tests to Python 3 syntax"
- 2to3 -w -n --no-diffs traits/testing || die
- fi
-}
-
-python_prepare_all() {
- sed -i -e "s/'-O3'//g" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- nosetests || die
-}