summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-13 07:16:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-13 08:57:33 +0200
commitd9f9e8c0d683180ef88b7d078db4bc6e579d9a43 (patch)
tree6ffef2000bb1c794afa5b5b4cd0588fbddd5bb75 /dev-python/trustme/trustme-0.9.0.ebuild
parentdev-python/awxkit: Bump to 19.3.0 (diff)
downloadgentoo-d9f9e8c0d683180ef88b7d078db4bc6e579d9a43.tar.gz
gentoo-d9f9e8c0d683180ef88b7d078db4bc6e579d9a43.tar.bz2
gentoo-d9f9e8c0d683180ef88b7d078db4bc6e579d9a43.zip
dev-python/trustme: Bump to 0.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trustme/trustme-0.9.0.ebuild')
-rw-r--r--dev-python/trustme/trustme-0.9.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/trustme/trustme-0.9.0.ebuild b/dev-python/trustme/trustme-0.9.0.ebuild
new file mode 100644
index 000000000000..3f23c392ed2b
--- /dev/null
+++ b/dev-python/trustme/trustme-0.9.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="#1 quality TLS certs while you wait, for the discerning tester"
+HOMEPAGE="https://github.com/python-trio/trustme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest