summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/turbokid
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/turbokid')
-rw-r--r--dev-python/turbokid/Manifest1
-rw-r--r--dev-python/turbokid/metadata.xml8
-rw-r--r--dev-python/turbokid/turbokid-1.0.5-r1.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/turbokid/Manifest b/dev-python/turbokid/Manifest
new file mode 100644
index 000000000000..a81d42f562cc
--- /dev/null
+++ b/dev-python/turbokid/Manifest
@@ -0,0 +1 @@
+DIST TurboKid-1.0.5.tar.gz 6878 SHA256 25ff2b8a0b8d62c02c188931bb7a51fe6d421ed6db538cc07a9332ce4093c962 SHA512 13a7aba4773ceb5c591c9b5f33b585161a6b6bd92f13169291c20e2cb77b10fe97e3f2d5596d0498add34728a36f6e0968f236fca87f1091a92eee68704222a4 WHIRLPOOL 404a86ce7d3e1034f956e247a9f2c5c8cf02ddae37b5044859b6a48956dc0d6e586943424d5b363ea05abf90fa3d2e223d52cc996f72f4f1dc9096e0cb411841
diff --git a/dev-python/turbokid/metadata.xml b/dev-python/turbokid/metadata.xml
new file mode 100644
index 000000000000..3dd032502ba8
--- /dev/null
+++ b/dev-python/turbokid/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">TurboKid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/turbokid/turbokid-1.0.5-r1.ebuild b/dev-python/turbokid/turbokid-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..60c979c247e4
--- /dev/null
+++ b/dev-python/turbokid/turbokid-1.0.5-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="TurboKid"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python template plugin that supports Kid templates"
+HOMEPAGE="http://pypi.python.org/pypi/TurboKid"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND=">=dev-python/kid-0.9.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}