summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-10-11 13:18:09 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-10-11 13:18:09 -0500
commit421f4e1472e8edbe6ace0433a5f44bcc066eea05 (patch)
tree36b213e0d30cda68776f57c639b22051931bc834 /dev-python/turbolift/turbolift-2.1.3.ebuild
parentnet-analyzer/icinga-web: cleanup (diff)
downloadgentoo-421f4e1472e8edbe6ace0433a5f44bcc066eea05.tar.gz
gentoo-421f4e1472e8edbe6ace0433a5f44bcc066eea05.tar.bz2
gentoo-421f4e1472e8edbe6ace0433a5f44bcc066eea05.zip
dev-python/turbolift: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/turbolift/turbolift-2.1.3.ebuild')
-rw-r--r--dev-python/turbolift/turbolift-2.1.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/turbolift/turbolift-2.1.3.ebuild b/dev-python/turbolift/turbolift-2.1.3.ebuild
new file mode 100644
index 000000000000..b5ce60f78527
--- /dev/null
+++ b/dev-python/turbolift/turbolift-2.1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+# tests are not distributed with the release tarball
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="Openstack Swift sync/backup utility"
+HOMEPAGE="https://github.com/cloudnull/turbolift/wiki"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools
+ test? (
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND=">=dev-python/prettytable-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/cloudlib-0.5.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${PYTHON} -m unit discover turbolift/tests || die "failed testsuite"
+}