summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-17 18:52:48 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-17 20:43:34 +0100
commite472bdbfcf39a48d4f0e57f6cc09e65db2a3fb44 (patch)
tree57b455c5b70f30f66a795c727a4574315d017778 /dev-python/tweepy
parentdev-python/tweepy: Fix tests (diff)
downloadgentoo-e472bdbfcf39a48d4f0e57f6cc09e65db2a3fb44.tar.gz
gentoo-e472bdbfcf39a48d4f0e57f6cc09e65db2a3fb44.tar.bz2
gentoo-e472bdbfcf39a48d4f0e57f6cc09e65db2a3fb44.zip
dev-python/tweepy: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/tweepy')
-rw-r--r--dev-python/tweepy/Manifest1
-rw-r--r--dev-python/tweepy/tweepy-3.5.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/tweepy/Manifest b/dev-python/tweepy/Manifest
index b05219b94660..cddeaa0a033b 100644
--- a/dev-python/tweepy/Manifest
+++ b/dev-python/tweepy/Manifest
@@ -1,2 +1,3 @@
DIST tweepy-2.3.tar.gz 52352 SHA256 bce05e6375d03b42ba7fef2a972635be6841dd0f26b86bc5704154d248cd29d7 SHA512 23317a507174e108cf8d13232aa467d892aba1789ee4f610eef4f5503b045841b5c85e8ae63ddcfd1e07178afbf3bf9f4a9fed939426411a8566f1c949b9b831 WHIRLPOOL b9adc746e498a0bde90dcb0b4a3ea5c6817e41c39980436ca42364dab21493b0201de6fb16a196b9f9171150d46cc1ad5e121710aaa62bf16b0875d0c6f73cd7
DIST tweepy-3.3.0.tar.gz 23624 SHA256 2eb0b1396a9dbb29568bb037e77f2123c504bdc4055ac011f2027f3833b27068 SHA512 ca50fa4989f4fe45850c56b8bf327e8eab4f2b6c00e0dd3ade67f60349861ebfc1daa68b7f55284b527951e321661e15df8c198a2ac35e20d4adf1d24bf9bee3 WHIRLPOOL a07325535089769d9c8c40fd451f46c51439f6b97b4627f0364000487f9742feefd6ae8932f7b80c937274f0e4a88be89475bb03c152e73ddd859ae6c7155b5a
+DIST tweepy-3.5.0.tar.gz 24348 SHA256 f00ccf5f48c30d559ce0b750dfe3b2df6668dc799d8ce276fd90bfaa68845a58 SHA512 cf87f0b7dea0ca444c17a3fdb9c2ebef814683c110511876c1997630b3202393276d3dd2de3b37fc21eb7a15382d22cc886109bda5a11b3d06a08081704c8c2a WHIRLPOOL 3fed8a0b7f7a388f386782731b004ba7f192534675372639c312be5fb09bb6a5f197366f88274d815ec0c5042f7803451e02eeac76fe61d3c1301539d36f2c57
diff --git a/dev-python/tweepy/tweepy-3.5.0.ebuild b/dev-python/tweepy/tweepy-3.5.0.ebuild
new file mode 100644
index 000000000000..263fad6e34b6
--- /dev/null
+++ b/dev-python/tweepy/tweepy-3.5.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library for accessing the Twitter API "
+HOMEPAGE="https://tweepy.github.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RESTRICT="test" #missing in tarball
+
+DEPEND="
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+RDEPEND="
+ >=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.3[${PYTHON_USEDEP}]
+"
+python_prepare_all() {
+ # Required to avoid file collisions at install
+ sed \
+ -e "/find_packages/s:]:,'tests.*','examples']:g" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v -c tests/travis-tests.cfg || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}