summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-22 00:48:24 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-22 00:51:32 +0200
commit75fbc08b8a0850582cb9f74a5ae648bf9a6a8761 (patch)
tree595bc6eeb3f8be23d846453ceadac23ee06b32eb /dev-python/twine
parentdev-python/treq: Remove old (diff)
downloadgentoo-75fbc08b8a0850582cb9f74a5ae648bf9a6a8761.tar.gz
gentoo-75fbc08b8a0850582cb9f74a5ae648bf9a6a8761.tar.bz2
gentoo-75fbc08b8a0850582cb9f74a5ae648bf9a6a8761.zip
dev-python/twine: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/twine')
-rw-r--r--dev-python/twine/Manifest1
-rw-r--r--dev-python/twine/files/twine-1.15.0-tests.patch21
-rw-r--r--dev-python/twine/twine-1.15.0.ebuild49
3 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/twine/Manifest b/dev-python/twine/Manifest
index cfa3a8d3d0f1..5879478ddd52 100644
--- a/dev-python/twine/Manifest
+++ b/dev-python/twine/Manifest
@@ -1,2 +1 @@
-DIST twine-1.15.0.tar.gz 135851 BLAKE2B 5e85c30e23615e9fa7e40ed767412560b29c42ec777afbb17850781a384bc2d3787534a8114a65ac2374ab80441eb2d3b6d75dcff400e7b47a42453a9210130d SHA512 e0eae05c108e1e766a0a8ec684e3423b0537c8aa671675f30403171fd4f48ec65666d407df53f6dd9eefa0b98e5fd2fdf7dbf1f0f9150686c499de131f6f2435
DIST twine-3.2.0.tar.gz 145280 BLAKE2B b25fa984486a375e09705703a47994b529f6e5b48c6733c0a07b57bec6c0dfcdf4096d6ac6b0f9b7a7bfebfb32ea1cfb49c5de79f29495eb2a8fc59a5f8de4e5 SHA512 9959430913ea570d22f2d8b94e929af36b409b71691b3f66de8ddb77cfbfbe36590e21a6062db2a4a4f56ce2eb96984b0a474a93ea96b7734f53ada7a6411c28
diff --git a/dev-python/twine/files/twine-1.15.0-tests.patch b/dev-python/twine/files/twine-1.15.0-tests.patch
deleted file mode 100644
index ce75469c091f..000000000000
--- a/dev-python/twine/files/twine-1.15.0-tests.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/tests/test_package.py b/tests/test_package.py
-index 8e4fbbb..35c9c52 100644
---- a/tests/test_package.py
-+++ b/tests/test_package.py
-@@ -214,11 +214,11 @@ TWINE_1_5_0_WHEEL_HEXDIGEST = package.Hexdigest(
- 'b657a4148d05bd0098c1d6d8cc4e14e766dbe93c3a5ab6723b969da27a87bac0',
- )
-
--if platform.python_implementation().lower() == 'pypy':
-- # pyblake2 refuses to install on PyPy
-- TWINE_1_5_0_WHEEL_HEXDIGEST = TWINE_1_5_0_WHEEL_HEXDIGEST._replace(
-- blake2=None,
-- )
-+#if platform.python_implementation().lower() == 'pypy':
-+# # pyblake2 refuses to install on PyPy
-+# TWINE_1_5_0_WHEEL_HEXDIGEST = TWINE_1_5_0_WHEEL_HEXDIGEST._replace(
-+# blake2=None,
-+# )
-
-
- def test_hash_manager():
diff --git a/dev-python/twine/twine-1.15.0.ebuild b/dev-python/twine/twine-1.15.0.ebuild
deleted file mode 100644
index e281b95ed916..000000000000
--- a/dev-python/twine/twine-1.15.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of utilities for publishing packages on PyPI"
-HOMEPAGE="https://twine.readthedocs.io/ https://github.com/pypa/twine https://pypi.org/project/twine/"
-SRC_URI="https://github.com/pypa/twine/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- >=dev-python/tqdm-4.14[${PYTHON_USEDEP}]
- >=dev-python/pkginfo-1.4.2[${PYTHON_USEDEP}]
- >=dev-python/readme_renderer-21.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/twine-1.15.0-tests.patch"
-)
-
-python_prepare_all() {
- # requires internet
- rm -f tests/test_integration.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}